Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58727

Misleading log message when no e-mail is sent

    Details

    • Type: Improvement
    • Status: Open (View Workflow)
    • Priority: Trivial
    • Resolution: Unresolved
    • Component/s: mailer-plugin
    • Labels:
      None
    • Environment:
      mailer 1.24, Jenkins 2.176.2
    • Similar Issues:

      Description

      Given the attached Groovy pipeline script (irrelevant parts removed), mailer plugin complais with the following error message: 
      No mail will be sent out, as 'XXX' does not have a result yet. Please make sure you set a proper result in case of pipeline/build scripts.
      It complains even though the build result is SUCCESS.

      It worked several days ago, before an update of Jenkins and certain plugins.+

       

      Is there anybody experiencing a similar issue? Maybe there is something wrong in my script, but it worked before, during months.

      If there is any workaround to avoid this, it will be welcome

       EDIT: When no e-mail has to be sent, a misleading message is printed in build log. I would not consider this a bug, but removing this message (or changing its text) would be an improvement

        Attachments

          Activity

          Hide
          carlosgarcia Carlos Garcia added a comment - - edited

          It seems to be only a misleading log message coming from mailer plugin.

          When the plugin is expected to send an e-mail (i.e: the build fails, or changes to normal after a failure), the log is not printed out and the e-mail is sent. When the build was SUCCESS and it is SUCCESS again, no e-mail is expected to be sent, and no e-mail is sent, but this log appears.

          It is safe to simply ignore the message.

           

          EDIT: Please, you can close the issue  And sorry for the alarm.

          Show
          carlosgarcia Carlos Garcia added a comment - - edited It seems to be only a misleading log message coming from mailer plugin. When the plugin is expected to send an e-mail (i.e: the build fails, or changes to normal after a failure), the log is not printed out and the e-mail is sent. When the build was SUCCESS and it is SUCCESS again, no e-mail is expected to be sent, and no e-mail is sent, but this log appears. It is safe to simply ignore the message.   EDIT: Please, you can close the issue  And sorry for the alarm.
          Hide
          haratsu Hagen Rahn added a comment -

          In fact this missleading message should be fixed, although the impact seems tiny, several of my users already asked me about it.

          Show
          haratsu Hagen Rahn added a comment - In fact this missleading message should be fixed, although the impact seems tiny, several of my users already asked me about it.

            People

            • Assignee:
              alecharp Adrien Lecharpentier
              Reporter:
              carlosgarcia Carlos Garcia
            • Votes:
              4 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: