Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58820

scan Multibranch pipeline does not detect new streams when file is branch

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: p4-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      P4_plugin will  not detect new streams in a multiBranch Scan if the Jenkinsfile`s change action is branch.  Once the file is edited once (thus changing the action to edit) the multibranch scan that will be run next will succeed in finding the new stream and add it's config.

      Since we have a highly uniform environment based on conventions edition of the Jenkinsfile for development branch from a mainline is rarely necessary.  99% of the time programmers will only create the stream and work on their things without needing to touch the Jenkins file at all.

       

      for example, the scan multibranch pipeline log returns this

       
       

       p4 files -e //proj/demos/2019.2/Jenkinsfile //proj/demos/2019.2/Jenkinsfile - no such file(s).
      ‘Jenkinsfile’ not found
      

       

      while running the very same command line locally will yield :

       

      p4 files -e //proj/demos/2019.2/Jenkinsfile
      //proj/demos/2019.2/Jenkinsfile#1 - branch change 2190857 (text)
       
      

       

      editing the file with a bogus change yields this locally :

      > p4 files -e //proj/demos/2019.2/Jenkinsfile
      //proj/demos/2019.2/Jenkinsfile#2 - edit change 2191573 (text)

       

      and running the scan multibranch manually yields this log

       

      p4 files -e //proj/demos/2019.2/Jenkinsfile 
      
      p4 files -e //proj/demos/2019.2/Jenkinsfile //proj/demos/2019.2/Jenkinsfile#2 - edit change 2191573 (text) ‘Jenkinsfile’ found 

       
       
      and the stream is detected and a build properly scheduled.

        Attachments

          Issue Links

            Activity

            joel_brown Joel Brown added a comment -

            Hi Eric Daigneault - does your company have a Perforce License?   If so, I'd prefer to work with you through our Salesforce on the issue.  And then update this with any conclusion.

            joel_brown Joel Brown added a comment - - edited

            Eric Daigneault What type of Stream is this undetected stream?   Development?  Release?  Task?

            I can reproduce this with a Task stream.   Please confirm you have the problem with Task Streams - or other.

            newtopian Eric Daigneault added a comment -

            wow... closed already !

             

            well, it occurred on development stream.  We do not (yet) use task streams in our process with Jenkins.

             

            We do have a perforce Licence, I will talk to our perforce guru in-house see if he or someone else that has access to, can create an issue with support directly

            newtopian Eric Daigneault added a comment -

            not related to linked issue, this occurred with development stream not task stream

            joel_brown Joel Brown added a comment -

            Eric Daigneault if your "p4 -ztag info" shows support you can email support@perforce.com (please provide the p4 info).  Please mention me.

            newtopian Eric Daigneault added a comment -

            restoring the duplicate status.  Could not reproduce on development stream, stream at the time could have been task stream.


              People

              • Assignee:
                joel_brown Joel Brown
                Reporter:
                newtopian Eric Daigneault
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: