Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59078

jenkins Malformed POM Unknown attribute 'child.scm.url.inherit.append.path' for tag 'scm'

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      centos 7 x64 JDK 1.8
    • Similar Issues:

      Description

      It builds just fine in maven 3.6.1, Jenkins configured to use 3.6.1

       > git submodule update --init --recursive mojo-lombok-issue-fix-18
      Parsing POMs
      ERROR: Failed to parse POMs
      hudson.remoting.ProxyException: hudson.maven.MavenModuleSetBuild$MavenExecutionException: org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
      [ERROR] Malformed POM /var/lib/jenkins/workspace/xxx/pom.xml: Unknown attribute 'child.scm.url.inherit.append.path' for tag 'scm' (position: START_TAG seen ...</modules>\n\n  <scm child.scm.url.inherit.append.path="false">... @39:50)  @ /var/lib/jenkins/workspace/xxx/pom.xml, line 39, column 50
      
      	at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1390)
      	at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1126)
      	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:3052)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:211)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:54)
      	at hudson.remoting.Request$2.run(Request.java:369)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
      	at java.lang.Thread.run(Thread.java:748)
      	Suppressed: hudson.remoting.Channel$CallSiteStackTrace: Remote call to pdinc-dte-jenkins-centos7-x86_64
      		at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1741)
      		at hudson.remoting.UserRequest$ExceptionResponse.retrieve(UserRequest.java:356)
      		at hudson.remoting.Channel.call(Channel.java:955)
      		at hudson.FilePath.act(FilePath.java:1072)
      		at hudson.FilePath.act(FilePath.java:1061)
      		at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.parsePoms(MavenModuleSetBuild.java:987)
      		at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:691)
      		at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
      		at hudson.model.Run.execute(Run.java:1815)
      		at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
      		at hudson.model.ResourceController.execute(ResourceController.java:97)
      		at hudson.model.Executor.run(Executor.java:429)
      Caused by: hudson.remoting.ProxyException: org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
      [ERROR] Malformed POM /var/lib/jenkins/workspace/xxx/pom.xml: Unknown attribute 'child.scm.url.inherit.append.path' for tag 'scm' (position: START_TAG seen ...</modules>\n\n  <scm child.scm.url.inherit.append.path="false">... @39:50)  @ /var/lib/jenkins/workspace/xxx/pom.xml, line 39, column 50
      
      	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:383)
      	at hudson.maven.MavenEmbedder.buildProjects(MavenEmbedder.java:370)
      	at hudson.maven.MavenEmbedder.readProjects(MavenEmbedder.java:340)
      	at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1329)
      	... 10 more
      Sending e-mails to: xxx
      Finished: FAILURE
      

        Attachments

          Activity

          Hide
          jpyeron Jason Pyeron added a comment -

          A similar example...

          Show
          jpyeron Jason Pyeron added a comment - A similar example...
          Hide
          jpyeron Jason Pyeron added a comment -

          I gave a small effort to patch https://github.com/jenkinsci/maven-plugin , but I hit a brick wall on trying to update the maven-core to 3.6.x

          maven barf on 3.6.0
          [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce (display-info) @ maven-plugin ---
          [INFO] Adding ignore: module-info
          [INFO] Ignoring requireUpperBoundDeps in com.google.guava:guava
          [INFO] Ignoring requireUpperBoundDeps in com.google.code.findbugs:jsr305
          [WARNING] Rule 4: org.apache.maven.plugins.enforcer.RequireUpperBoundDeps failed with message:
          Failed while enforcing RequireUpperBoundDeps. The error(s) are [
          Require upper bound dependencies error for org.codehaus.plexus:plexus-utils:3.1.0 paths to dependency are:
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main.maven:maven-interceptor:1.13
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main.maven:maven3-agent:1.13
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main.maven:maven35-agent:1.13
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main.maven:maven31-interceptor:1.13
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main.maven:maven32-interceptor:1.13
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main.maven:maven33-interceptor:1.13
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main.maven:maven35-interceptor:1.13
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main.maven:maven3-interceptor-commons:1.13
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-compat:3.6.1
              +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-repository-metadata:3.6.1
              +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-resolver-provider:3.6.1
              +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-embedder:3.6.1
              +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.eclipse.sisu:org.eclipse.sisu.plexus:0.3.3
              +-org.codehaus.plexus:plexus-utils:3.0.17
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.wagon:wagon-http:3.3.2
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.wagon:wagon-file:3.3.2
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.wagon:wagon-ssh:3.3.2
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.wagon:wagon-ssh-external:3.3.2
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.wagon:wagon-provider-api:3.3.2
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.lib:lib-jenkins-maven-artifact-manager:1.2
              +-org.codehaus.plexus:plexus-utils:2.0.5
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.wagon:wagon-webdav-jackrabbit:3.3.2
              +-org.codehaus.plexus:plexus-utils:3.1.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven:maven-model:3.6.1
                +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven:maven-settings:3.6.1
                +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven:maven-settings-builder:3.6.1
                +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven:maven-artifact:3.6.1
                +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven:maven-plugin-api:3.6.1
                +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven:maven-model-builder:3.6.1
                +-org.codehaus.plexus:plexus-utils:3.2.0
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-embedder:3.6.1
              +-org.sonatype.plexus:plexus-sec-dispatcher:1.4
                +-org.codehaus.plexus:plexus-utils:1.5.5
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.wagon:wagon-ssh:3.3.2
              +-org.codehaus.plexus:plexus-interactivity-api:1.0-alpha-6
                +-org.codehaus.plexus:plexus-utils:1.4
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.wagon:wagon-ssh:3.3.2
              +-org.apache.maven.wagon:wagon-ssh-common:3.3.2
                +-org.codehaus.plexus:plexus-utils:3.1.0
          ,
          Require upper bound dependencies error for org.codehaus.plexus:plexus-interpolation:1.24 paths to dependency are:
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main.maven:maven35-agent:1.13
              +-org.codehaus.plexus:plexus-interpolation:1.24
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-compat:3.6.1
              +-org.codehaus.plexus:plexus-interpolation:1.25
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven:maven-settings-builder:3.6.1
                +-org.codehaus.plexus:plexus-interpolation:1.25
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven:maven-model-builder:3.6.1
                +-org.codehaus.plexus:plexus-interpolation:1.25
          ,
          Require upper bound dependencies error for org.apache.commons:commons-lang3:3.7 paths to dependency are:
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.commons:commons-lang3:3.7
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.commons:commons-lang3:3.8.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-embedder:3.6.1
              +-org.apache.commons:commons-lang3:3.8.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven:maven-artifact:3.6.1
                +-org.apache.commons:commons-lang3:3.8.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main:jenkins-test-harness:2.49
              +-org.jenkins-ci.main:jenkins-test-harness-htmlunit:2.31-2
                +-org.apache.commons:commons-lang3:3.7
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.main:jenkins-test-harness:2.49
              +-org.jenkins-ci.main:jenkins-test-harness-htmlunit:2.31-2
                +-org.apache.commons:commons-text:1.3
                  +-org.apache.commons:commons-lang3:3.7
          ,
          Require upper bound dependencies error for org.apache.maven.resolver:maven-resolver-impl:1.1.1 paths to dependency are:
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-impl:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven.resolver:maven-resolver-impl:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-compat:3.6.1
              +-org.apache.maven.resolver:maven-resolver-impl:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-resolver-provider:3.6.1
              +-org.apache.maven.resolver:maven-resolver-impl:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.lib:lib-jenkins-maven-embedder:3.14
              +-org.apache.maven.resolver:maven-resolver-impl:1.1.1
          ,
          Require upper bound dependencies error for org.apache.maven.resolver:maven-resolver-api:1.1.1 paths to dependency are:
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-api:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven.resolver:maven-resolver-api:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-compat:3.6.1
              +-org.apache.maven.resolver:maven-resolver-api:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-resolver-provider:3.6.1
              +-org.apache.maven.resolver:maven-resolver-api:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-embedder:3.6.1
              +-org.apache.maven.resolver:maven-resolver-api:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-impl:1.1.1
              +-org.apache.maven.resolver:maven-resolver-api:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-spi:1.1.1
              +-org.apache.maven.resolver:maven-resolver-api:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-util:1.1.1
              +-org.apache.maven.resolver:maven-resolver-api:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-transport-wagon:1.1.1
              +-org.apache.maven.resolver:maven-resolver-api:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-connector-basic:1.1.1
              +-org.apache.maven.resolver:maven-resolver-api:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.lib:lib-jenkins-maven-embedder:3.14
              +-org.apache.maven.resolver:maven-resolver-api:1.1.1
          ,
          Require upper bound dependencies error for org.apache.maven.resolver:maven-resolver-spi:1.1.1 paths to dependency are:
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-spi:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven.resolver:maven-resolver-spi:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-resolver-provider:3.6.1
              +-org.apache.maven.resolver:maven-resolver-spi:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-impl:1.1.1
              +-org.apache.maven.resolver:maven-resolver-spi:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-transport-wagon:1.1.1
              +-org.apache.maven.resolver:maven-resolver-spi:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-connector-basic:1.1.1
              +-org.apache.maven.resolver:maven-resolver-spi:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.lib:lib-jenkins-maven-embedder:3.14
              +-org.apache.maven.resolver:maven-resolver-spi:1.1.1
          ,
          Require upper bound dependencies error for org.apache.maven.resolver:maven-resolver-util:1.1.1 paths to dependency are:
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-util:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-core:3.6.1
              +-org.apache.maven.resolver:maven-resolver-util:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-compat:3.6.1
              +-org.apache.maven.resolver:maven-resolver-util:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-resolver-provider:3.6.1
              +-org.apache.maven.resolver:maven-resolver-util:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven:maven-embedder:3.6.1
              +-org.apache.maven.resolver:maven-resolver-util:1.3.3
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-impl:1.1.1
              +-org.apache.maven.resolver:maven-resolver-util:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-transport-wagon:1.1.1
              +-org.apache.maven.resolver:maven-resolver-util:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.apache.maven.resolver:maven-resolver-connector-basic:1.1.1
              +-org.apache.maven.resolver:maven-resolver-util:1.1.1
          and
          +-org.jenkins-ci.main:maven-plugin:3.4.0.4
            +-org.jenkins-ci.lib:lib-jenkins-maven-embedder:3.14
              +-org.apache.maven.resolver:maven-resolver-util:1.1.1
          ]
          

          The issue lies in https://github.com/jenkinsci/lib-jenkins-maven-embedder/tree/master using 3.5.4 and not 3.6.x

          A better set of stack traces
          Parsing POMs
          Parsing POMs...invoked
          org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
          [ERROR] Malformed POM /var/lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml: Unknown attribute 'child.scm.url.inherit.append.path' for tag 'scm' (position: START_TAG seen ...</modules>\n\n  <scm child.scm.url.inherit.append.path="false">... @39:50)  @ /var/lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml, line 39, column 50
          
          	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:383)
          	at hudson.maven.MavenEmbedder.buildProjects(MavenEmbedder.java:370)
          	at hudson.maven.MavenEmbedder.readProjects(MavenEmbedder.java:340)
          	at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1333)
          	at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1128)
          	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:3052)
          	at hudson.remoting.UserRequest.perform(UserRequest.java:211)
          	at hudson.remoting.UserRequest.perform(UserRequest.java:54)
          	at hudson.remoting.Request$2.run(Request.java:369)
          	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
          	at java.lang.Thread.run(Thread.java:748)
          ERROR: Failed to parse POMs
          hudson.remoting.ProxyException: hudson.maven.MavenModuleSetBuild$MavenExecutionException: org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
          [ERROR] Malformed POM /var/lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml: Unknown attribute 'child.scm.url.inherit.append.path' for tag 'scm' (position: START_TAG seen ...</modules>\n\n  <scm child.scm.url.inherit.append.path="false">... @39:50)  @ /var/lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml, line 39, column 50
          
          	at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1395)
          	at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1128)
          	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:3052)
          	at hudson.remoting.UserRequest.perform(UserRequest.java:211)
          	at hudson.remoting.UserRequest.perform(UserRequest.java:54)
          	at hudson.remoting.Request$2.run(Request.java:369)
          	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
          	at java.lang.Thread.run(Thread.java:748)
          	Suppressed: hudson.remoting.Channel$CallSiteStackTrace: Remote call to pdinc-dte-jenkins-centos7-x86_64
          		at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1741)
          		at hudson.remoting.UserRequest$ExceptionResponse.retrieve(UserRequest.java:356)
          		at hudson.remoting.Channel.call(Channel.java:955)
          		at hudson.FilePath.act(FilePath.java:1072)
          		at hudson.FilePath.act(FilePath.java:1061)
          		at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.parsePoms(MavenModuleSetBuild.java:989)
          		at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:691)
          		at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
          		at hudson.model.Run.execute(Run.java:1815)
          		at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
          		at hudson.model.ResourceController.execute(ResourceController.java:97)
          		at hudson.model.Executor.run(Executor.java:429)
          Caused by: hudson.remoting.ProxyException: org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
          [ERROR] Malformed POM /var/lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml: Unknown attribute 'child.scm.url.inherit.append.path' for tag 'scm' (position: START_TAG seen ...</modules>\n\n  <scm child.scm.url.inherit.append.path="false">... @39:50)  @ /var/lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml, line 39, column 50
          
          	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:383)
          	at hudson.maven.MavenEmbedder.buildProjects(MavenEmbedder.java:370)
          	at hudson.maven.MavenEmbedder.readProjects(MavenEmbedder.java:340)
          	at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1333)
          	... 10 more
          Finished: FAILURE
          

          To make the line numbers make sense, apply the following patch to 88159f70f1051607fbe77aa919fbf8367854525f

          Unable to find source-code formatter for language: titlesrc/main/java/hudson/maven/mavenmodulesetbuild.java.patch. Available languages are: actionscript, ada, applescript, bash, c, c#, c++, cpp, css, erlang, go, groovy, haskell, html, java, javascript, js, json, lua, none, nyan, objc, perl, php, python, r, rainbow, ruby, scala, sh, sql, swift, visualbasic, xml, yaml
          $ git diff src/main/java/hudson/maven/MavenModuleSetBuild.java
          diff --git a/src/main/java/hudson/maven/MavenModuleSetBuild.java b/src/main/java/hudson/maven/MavenModuleSetBuild.java
          index 2ab2e5b..12ac6db 100755
          --- a/src/main/java/hudson/maven/MavenModuleSetBuild.java
          +++ b/src/main/java/hudson/maven/MavenModuleSetBuild.java
          @@ -984,7 +984,9 @@ public class MavenModuleSetBuild extends AbstractMavenBuild<MavenModuleSet,Maven
          
                       List<PomInfo> poms;
                       try {
          -                PomParser.Result result = getModuleRoot().act(new PomParser(listener, mvn, mavenVersion, envVars, MavenModuleSetBuild.this));
          +                PomParser pp = new PomParser(listener, mvn, mavenVersion, envVars, MavenModuleSetBuild.this);
          +                FilePath r = getModuleRoot();
          +                PomParser.Result result = r.act(pp);
                           poms = result.infos;
                           mavenBuildInformation.modelParents.putAll(result.modelParents);
                       } catch (IOException e) {
          @@ -1226,6 +1228,8 @@ public class MavenModuleSetBuild extends AbstractMavenBuild<MavenModuleSet,Maven
          
                       PrintStream logger = listener.getLogger();
          
          +            logger.println("Parsing POMs...invoked");
          +
                       if (IOUtils.isAbsolute(rootPOM)) {
                           pom = new File(rootPOM);
                       } else {
          @@ -1387,6 +1391,7 @@ public class MavenModuleSetBuild extends AbstractMavenBuild<MavenModuleSet,Maven
          
                           return new Result(new ArrayList<>(infos), modelParents);
                       } catch (MavenEmbedderException | ProjectBuildingException e) {
          +                e.printStackTrace(logger);
                           throw new MavenExecutionException(e);
                       }
                   }
          
          Show
          jpyeron Jason Pyeron added a comment - I gave a small effort to patch https://github.com/jenkinsci/maven-plugin , but I hit a brick wall on trying to update the maven-core to 3.6.x maven barf on 3.6.0 [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce (display-info) @ maven-plugin --- [INFO] Adding ignore: module-info [INFO] Ignoring requireUpperBoundDeps in com.google.guava:guava [INFO] Ignoring requireUpperBoundDeps in com.google.code.findbugs:jsr305 [WARNING] Rule 4: org.apache.maven.plugins.enforcer.RequireUpperBoundDeps failed with message: Failed while enforcing RequireUpperBoundDeps. The error(s) are [ Require upper bound dependencies error for org.codehaus.plexus:plexus-utils:3.1.0 paths to dependency are: +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main.maven:maven-interceptor:1.13 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main.maven:maven3-agent:1.13 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main.maven:maven35-agent:1.13 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main.maven:maven31-interceptor:1.13 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main.maven:maven32-interceptor:1.13 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main.maven:maven33-interceptor:1.13 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main.maven:maven35-interceptor:1.13 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main.maven:maven3-interceptor-commons:1.13 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-compat:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-repository-metadata:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-resolver-provider:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-embedder:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.eclipse.sisu:org.eclipse.sisu.plexus:0.3.3 +-org.codehaus.plexus:plexus-utils:3.0.17 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.wagon:wagon-http:3.3.2 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.wagon:wagon-file:3.3.2 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.wagon:wagon-ssh:3.3.2 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.wagon:wagon-ssh-external:3.3.2 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.wagon:wagon-provider-api:3.3.2 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.lib:lib-jenkins-maven-artifact-manager:1.2 +-org.codehaus.plexus:plexus-utils:2.0.5 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.wagon:wagon-webdav-jackrabbit:3.3.2 +-org.codehaus.plexus:plexus-utils:3.1.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven:maven-model:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven:maven-settings:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven:maven-settings-builder:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven:maven-artifact:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven:maven-plugin-api:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven:maven-model-builder:3.6.1 +-org.codehaus.plexus:plexus-utils:3.2.0 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-embedder:3.6.1 +-org.sonatype.plexus:plexus-sec-dispatcher:1.4 +-org.codehaus.plexus:plexus-utils:1.5.5 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.wagon:wagon-ssh:3.3.2 +-org.codehaus.plexus:plexus-interactivity-api:1.0-alpha-6 +-org.codehaus.plexus:plexus-utils:1.4 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.wagon:wagon-ssh:3.3.2 +-org.apache.maven.wagon:wagon-ssh-common:3.3.2 +-org.codehaus.plexus:plexus-utils:3.1.0 , Require upper bound dependencies error for org.codehaus.plexus:plexus-interpolation:1.24 paths to dependency are: +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main.maven:maven35-agent:1.13 +-org.codehaus.plexus:plexus-interpolation:1.24 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-compat:3.6.1 +-org.codehaus.plexus:plexus-interpolation:1.25 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven:maven-settings-builder:3.6.1 +-org.codehaus.plexus:plexus-interpolation:1.25 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven:maven-model-builder:3.6.1 +-org.codehaus.plexus:plexus-interpolation:1.25 , Require upper bound dependencies error for org.apache.commons:commons-lang3:3.7 paths to dependency are: +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.commons:commons-lang3:3.7 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.commons:commons-lang3:3.8.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-embedder:3.6.1 +-org.apache.commons:commons-lang3:3.8.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven:maven-artifact:3.6.1 +-org.apache.commons:commons-lang3:3.8.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main:jenkins-test-harness:2.49 +-org.jenkins-ci.main:jenkins-test-harness-htmlunit:2.31-2 +-org.apache.commons:commons-lang3:3.7 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.main:jenkins-test-harness:2.49 +-org.jenkins-ci.main:jenkins-test-harness-htmlunit:2.31-2 +-org.apache.commons:commons-text:1.3 +-org.apache.commons:commons-lang3:3.7 , Require upper bound dependencies error for org.apache.maven.resolver:maven-resolver-impl:1.1.1 paths to dependency are: +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-impl:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven.resolver:maven-resolver-impl:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-compat:3.6.1 +-org.apache.maven.resolver:maven-resolver-impl:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-resolver-provider:3.6.1 +-org.apache.maven.resolver:maven-resolver-impl:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.lib:lib-jenkins-maven-embedder:3.14 +-org.apache.maven.resolver:maven-resolver-impl:1.1.1 , Require upper bound dependencies error for org.apache.maven.resolver:maven-resolver-api:1.1.1 paths to dependency are: +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-api:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven.resolver:maven-resolver-api:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-compat:3.6.1 +-org.apache.maven.resolver:maven-resolver-api:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-resolver-provider:3.6.1 +-org.apache.maven.resolver:maven-resolver-api:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-embedder:3.6.1 +-org.apache.maven.resolver:maven-resolver-api:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-impl:1.1.1 +-org.apache.maven.resolver:maven-resolver-api:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-spi:1.1.1 +-org.apache.maven.resolver:maven-resolver-api:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-util:1.1.1 +-org.apache.maven.resolver:maven-resolver-api:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-transport-wagon:1.1.1 +-org.apache.maven.resolver:maven-resolver-api:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-connector-basic:1.1.1 +-org.apache.maven.resolver:maven-resolver-api:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.lib:lib-jenkins-maven-embedder:3.14 +-org.apache.maven.resolver:maven-resolver-api:1.1.1 , Require upper bound dependencies error for org.apache.maven.resolver:maven-resolver-spi:1.1.1 paths to dependency are: +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-spi:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven.resolver:maven-resolver-spi:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-resolver-provider:3.6.1 +-org.apache.maven.resolver:maven-resolver-spi:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-impl:1.1.1 +-org.apache.maven.resolver:maven-resolver-spi:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-transport-wagon:1.1.1 +-org.apache.maven.resolver:maven-resolver-spi:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-connector-basic:1.1.1 +-org.apache.maven.resolver:maven-resolver-spi:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.lib:lib-jenkins-maven-embedder:3.14 +-org.apache.maven.resolver:maven-resolver-spi:1.1.1 , Require upper bound dependencies error for org.apache.maven.resolver:maven-resolver-util:1.1.1 paths to dependency are: +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-util:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-core:3.6.1 +-org.apache.maven.resolver:maven-resolver-util:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-compat:3.6.1 +-org.apache.maven.resolver:maven-resolver-util:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-resolver-provider:3.6.1 +-org.apache.maven.resolver:maven-resolver-util:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven:maven-embedder:3.6.1 +-org.apache.maven.resolver:maven-resolver-util:1.3.3 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-impl:1.1.1 +-org.apache.maven.resolver:maven-resolver-util:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-transport-wagon:1.1.1 +-org.apache.maven.resolver:maven-resolver-util:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.apache.maven.resolver:maven-resolver-connector-basic:1.1.1 +-org.apache.maven.resolver:maven-resolver-util:1.1.1 and +-org.jenkins-ci.main:maven-plugin:3.4.0.4 +-org.jenkins-ci.lib:lib-jenkins-maven-embedder:3.14 +-org.apache.maven.resolver:maven-resolver-util:1.1.1 ] The issue lies in https://github.com/jenkinsci/lib-jenkins-maven-embedder/tree/master using 3.5.4 and not 3.6.x A better set of stack traces Parsing POMs Parsing POMs...invoked org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs: [ERROR] Malformed POM / var /lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml: Unknown attribute 'child.scm.url.inherit.append.path' for tag 'scm' (position: START_TAG seen ...</modules>\n\n <scm child.scm.url.inherit.append.path= " false " >... @39:50) @ / var /lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml, line 39, column 50 at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:383) at hudson.maven.MavenEmbedder.buildProjects(MavenEmbedder.java:370) at hudson.maven.MavenEmbedder.readProjects(MavenEmbedder.java:340) at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1333) at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1128) at hudson.FilePath$FileCallableWrapper.call(FilePath.java:3052) at hudson.remoting.UserRequest.perform(UserRequest.java:211) at hudson.remoting.UserRequest.perform(UserRequest.java:54) at hudson.remoting.Request$2.run(Request.java:369) at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang. Thread .run( Thread .java:748) ERROR: Failed to parse POMs hudson.remoting.ProxyException: hudson.maven.MavenModuleSetBuild$MavenExecutionException: org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs: [ERROR] Malformed POM / var /lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml: Unknown attribute 'child.scm.url.inherit.append.path' for tag 'scm' (position: START_TAG seen ...</modules>\n\n <scm child.scm.url.inherit.append.path= " false " >... @39:50) @ / var /lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml, line 39, column 50 at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1395) at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1128) at hudson.FilePath$FileCallableWrapper.call(FilePath.java:3052) at hudson.remoting.UserRequest.perform(UserRequest.java:211) at hudson.remoting.UserRequest.perform(UserRequest.java:54) at hudson.remoting.Request$2.run(Request.java:369) at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang. Thread .run( Thread .java:748) Suppressed: hudson.remoting.Channel$CallSiteStackTrace: Remote call to pdinc-dte-jenkins-centos7-x86_64 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1741) at hudson.remoting.UserRequest$ExceptionResponse.retrieve(UserRequest.java:356) at hudson.remoting.Channel.call(Channel.java:955) at hudson.FilePath.act(FilePath.java:1072) at hudson.FilePath.act(FilePath.java:1061) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.parsePoms(MavenModuleSetBuild.java:989) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:691) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504) at hudson.model.Run.execute(Run.java:1815) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543) at hudson.model.ResourceController.execute(ResourceController.java:97) at hudson.model.Executor.run(Executor.java:429) Caused by: hudson.remoting.ProxyException: org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs: [ERROR] Malformed POM / var /lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml: Unknown attribute 'child.scm.url.inherit.append.path' for tag 'scm' (position: START_TAG seen ...</modules>\n\n <scm child.scm.url.inherit.append.path= " false " >... @39:50) @ / var /lib/jenkins/workspace/pdinc-oss-lombok.maven/pom.xml, line 39, column 50 at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:383) at hudson.maven.MavenEmbedder.buildProjects(MavenEmbedder.java:370) at hudson.maven.MavenEmbedder.readProjects(MavenEmbedder.java:340) at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1333) ... 10 more Finished: FAILURE To make the line numbers make sense, apply the following patch to 88159f70f1051607fbe77aa919fbf8367854525f Unable to find source-code formatter for language: titlesrc/main/java/hudson/maven/mavenmodulesetbuild.java.patch. Available languages are: actionscript, ada, applescript, bash, c, c#, c++, cpp, css, erlang, go, groovy, haskell, html, java, javascript, js, json, lua, none, nyan, objc, perl, php, python, r, rainbow, ruby, scala, sh, sql, swift, visualbasic, xml, yaml $ git diff src/main/java/hudson/maven/MavenModuleSetBuild.java diff --git a/src/main/java/hudson/maven/MavenModuleSetBuild.java b/src/main/java/hudson/maven/MavenModuleSetBuild.java index 2ab2e5b..12ac6db 100755 --- a/src/main/java/hudson/maven/MavenModuleSetBuild.java +++ b/src/main/java/hudson/maven/MavenModuleSetBuild.java @@ -984,7 +984,9 @@ public class MavenModuleSetBuild extends AbstractMavenBuild<MavenModuleSet,Maven List<PomInfo> poms; try { - PomParser.Result result = getModuleRoot().act( new PomParser(listener, mvn, mavenVersion, envVars, MavenModuleSetBuild. this )); + PomParser pp = new PomParser(listener, mvn, mavenVersion, envVars, MavenModuleSetBuild. this ); + FilePath r = getModuleRoot(); + PomParser.Result result = r.act(pp); poms = result.infos; mavenBuildInformation.modelParents.putAll(result.modelParents); } catch (IOException e) { @@ -1226,6 +1228,8 @@ public class MavenModuleSetBuild extends AbstractMavenBuild<MavenModuleSet,Maven PrintStream logger = listener.getLogger(); + logger.println( "Parsing POMs...invoked" ); + if (IOUtils.isAbsolute(rootPOM)) { pom = new File(rootPOM); } else { @@ -1387,6 +1391,7 @@ public class MavenModuleSetBuild extends AbstractMavenBuild<MavenModuleSet,Maven return new Result( new ArrayList<>(infos), modelParents); } catch (MavenEmbedderException | ProjectBuildingException e) { + e.printStackTrace(logger); throw new MavenExecutionException(e); } }
          Hide
          jpyeron Jason Pyeron added a comment -

          seems to be slightly relevant

          Show
          jpyeron Jason Pyeron added a comment - seems to be slightly relevant
          Hide
          hraja Harvey Raja added a comment -

          Any idea when this will be resolved?

          Show
          hraja Harvey Raja added a comment - Any idea when this will be resolved?

            People

            • Assignee:
              Unassigned
              Reporter:
              jpyeron Jason Pyeron
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: