Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59609

java.lang.NullPointerException on build project

    Details

    • Type: Bug
    • Status: In Progress (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: xcode-plugin
    • Labels:
      None
    • Environment:
      Jenkins v: 2.198
      XCode plugin: 2.0.12
      Build machine: MacMini, Mac OSX, Mohave 10.14.6
    • Similar Issues:

      Description

      I am having problems with building some of my older projects (3-4 years old). Projects use cocoapods. I have set up workspace file and scheme file like in some other projects that build without problems but it doesn't seam to work. When I open project from /.jenkins/workspace/ProjectName/project.xcworkspace with xCode and try to build it it works fine.

       

      This is my error log:

       

      Read signing information from Xcode Project. Read information from workspace AZFond ERROR: Build step failed with exception java.lang.NullPointerException at au.com.rayh.XCodeBuilder._perform(XCodeBuilder.java:1289) at au.com.rayh.XCodeBuilder.perform(XCodeBuilder.java:1085) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:741) at hudson.model.Build$BuildExecution.build(Build.java:206) at hudson.model.Build$BuildExecution.doRun(Build.java:163) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504) at hudson.model.Run.execute(Run.java:1838) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:97) at hudson.model.Executor.run(Executor.java:429) Build step 'Xcode' marked build as failure Email was triggered for: Failure - Any Sending email for trigger: Failure - Any

        Attachments

          Activity

          Hide
          aphex3k Michael Henke added a comment -

          I'm seeing the same issue with a brand new swift project for iOS failing to build right after adding the cocoa pod.

           

          Show
          aphex3k Michael Henke added a comment - I'm seeing the same issue with a brand new swift project for iOS failing to build right after adding the cocoa pod.  

            People

            • Assignee:
              kazuhidet Kazuhide Takahashi
              Reporter:
              antonijojira Antonijo Bezmalinovic
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: