Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59651

PIPELINE_VERSION can not export to shell environment.

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Critical
    • Resolution: Unresolved
    • Labels:
      None
    • Environment:
      jenkins-2.187.war osx jdk8 delivery-pipeline-plugin 1.4
    • Similar Issues:

      Description

      Then plugin works file when I use old jenkins release.

      When I upgrade jenkins to latest version. 

      I found shell env missing PIPELINE_VERSION  variable.

       

      Also test on delivery-pipeline-plugin 1.4.0 1.3.2

       

      clone git commit 04d7810b96af1ad893d761edf1e0e6faa79f72c9

      change <jenkins.version>2.187</jenkins.version>

      run mvn test

      There are  test failures.

        Attachments

          Activity

          Hide
          seanly Sean Ly added a comment - - edited

          version 1.4 has this problem, rolling back to 1.3 does not

          Show
          seanly Sean Ly added a comment - - edited version 1.4 has this problem, rolling back to 1.3 does not
          Hide
          adic26 Adi C added a comment -

          In my mind this is critical as this is breaking CI/CD process as the versioning is not set and developers cannot promote to higher environments. Is there a fix for this in the upcoming horizon?

          Show
          adic26 Adi C added a comment - In my mind this is critical as this is breaking CI/CD process as the versioning is not set and developers cannot promote to higher environments. Is there a fix for this in the upcoming horizon?

            People

            • Assignee:
              patbos Patrik Boström
              Reporter:
              lxbzmy Alex Lei
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: