Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59709

please update jackson-databind version

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: github-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.190 on centos 7
    • Similar Issues:
    • Released As:
      github 1.29.5

      Description

      /var/jenkins_home/plugins/github/WEB-INF/lib/jackson-databind-2.6.0.jar

      https://github.com/FasterXML/jackson-databind/issues/2334?spm=a2c4g.11174386.n2.3.424e1051fA53pZ

        Attachments

          Activity

          Hide
          dnusbaum Devin Nusbaum added a comment - - edited

          Based on the path you specify, it looks like the problem was that github plugin included Jackson as a direct dependency rather than using the jackson2-api plugin. I think that was fixed by this commit in github plugin version 1.29.5. Once you update to that version, you should be able to update jackson2-api plugin to the latest version to pick up a newer version of jackson-databind.

          Show
          dnusbaum Devin Nusbaum added a comment - - edited Based on the path you specify, it looks like the problem was that github plugin included Jackson as a direct dependency rather than using the jackson2-api plugin. I think that was fixed by this commit in github plugin version 1.29.5. Once you update to that version, you should be able to update jackson2-api plugin to the latest version to pick up a newer version of jackson-databind.

            People

            • Assignee:
              Unassigned
              Reporter:
              blankhang blank hang
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: