Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59866

Octane Cucumber test reporter plugin fails previous passed build after Jenkins restarts

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      Hi,

      I am currently having issue with "Octane Cucumber test reporter" plugin which could be reproduced as below steps:

      Steps:

      1. Create a Maven project using cucumber framework and "com.hpe.alm.octane.OctaneGherkinFormatter:target
        gherkin-results
        ManualRunnerTest_OctaneGherkinResults.xml" plugin.
      2. Create a freestyle Jenkins job for above maven project and add the "Octane Cucumber test reporter" and "Publish Thucydides Test Reports" to Post-build Actions.
      3. Create an Octane pipeline job that links to Jenkins job above.
      4. Build the job and ensure the result is passed.
      5. Validate the HTML report is published in Jenkins and ManualRunnerTest_OctaneGherkinResults.xml is generated in Jenkins workspace\target\gherkin-results.
      6. Restart Jenkins

      Expected:

      • Job status is still passed.
      • HTML Report is still accessible.

      Actual:

      • Job status is turned to failed.
      • HTML Report is removed.

      Please see attached the screenshots of the job status before and after Jenkins restart, console output log, and octane pipeline status.

        Attachments

          Activity

          radislavb Radi Berkovich added a comment -

          We found some issue with gherkin publisher that were fixed in v5.9.1-beta

          Its available here : 

          http://repo.jenkins-ci.org/releases/org/jenkins-ci/plugins/hp-application-automation-tools-plugin/5.9.1-beta/hp-application-automation-tools-plugin-5.9.1-beta.hpi

           Please try and update if it fix your issue.

           

           

          lambdaway Minh Tran added a comment -

          Thanks. The issue is now fixed in version 5.9.1-beta.


            People

            • Assignee:
              radislavb Radi Berkovich
              Reporter:
              lambdaway Minh Tran
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: