Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59907

sh steps stuck indefinitely on uncommon architectures (e.g. s390x)

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: durable-task-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.201 (yum installed, master node only)
      durable-task plugin v1.31

      os.arch: s390x
      os.name: Linux (RedHat)
      os.version: 3.10.0-327.el7.s390x
    • Similar Issues:
    • Released As:
      1.33

      Description

      After upgrading to v1.31, the first sh step in a pipeline gets stuck. After few minutes Console Output shows:

      [Pipeline] sh (Get email of the author of last commit)
      process apparently never started in /data/jenkins/workspace/TG2_PTG2_-_pipeline_build_master@tmp/durable-be2cf2a6
      (running Jenkins temporarily with -Dorg.jenkinsci.plugins.durabletask.BourneShellScript.LAUNCH_DIAGNOSTICS=true might make the problem clearer)
      Cannot contact : java.io.FileNotFoundException: File '/data/jenkins/workspace/TG2_PTG2_-_pipeline_build_master@tmp/durable-be2cf2a6/output.txt' does not exist

       

      Eventually, I discovered that a new binary was added in the latest version of this plugin. The script compile-binaries.sh in GitHub suggests that the binary is only built for Linux and MacOS.

       

      Sure enough, when I try to execute the binary myself on an architecture other than amd64, I get:

      -bash: /data/jenkins/caches/durable-task/durable_task_monitor_1.31_unix_64: cannot execute binary file

       

      Are other architectures or operating systems (Windows) not supported anymore?

        Attachments

          Issue Links

            Activity

            rw250155 Reiner Wirtz added a comment -

            We have a similar problem on AIX 7.2.
            The binary to start is of type ELF.

            rostertag Rafael Ostertag added a comment -

            Just for the record, this issue will also affect Solaris, NetBSD and OpenBSD, regardless of the architecture.

            As a side note, the name of the binary is misleading. It should be called durable_task_monitor_X.YZ_linux_amd64, because that is the only OS it can run natively.

            jessesimpson Jesse Simpson added a comment -

            I am running an agent on ppc64le and ran into this issue.  I will attempt to revert to 1.3.0.

            Thank you, Jenkins team, for your ongoing support.

            carroll Carroll Chiou added a comment -

            Version 1.33 has now been released. There is stricter checking on the platforms it runs on. I know not every case has been covered here. The binary is disabled by default so behavior should be simliar, if not same to 1.30

            jloucky Jakub L added a comment -

            I can confirm that v1.33 works fine on s390x. Thanks for the fix!


              People

              • Assignee:
                carroll Carroll Chiou
                Reporter:
                jloucky Jakub L
              • Votes:
                9 Vote for this issue
                Watchers:
                12 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: