Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59939

durable_task_monitor_1.31_unix_64: no such file or directory

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      Jenkins 2.190.1
      Docker version 1.13.1, build 8633870/1.13.1
      CentOS Linux release 7.7.1908 (Core)
    • Similar Issues:

      Description

      This just started happening today, but I cannot identify a cause.
      Pipeline script involving sh inside a Dockerfile agent.

      stage('Test') {
        agent {
          dockerfile {
            additionalBuildArgs "--tag jenkins/${dockerName}:${BRANCH_NAME}"
            args '--cap-add=SYS_ADMIN'
            reuseNode true
          }
        }
        environment {
          NG_PORT = PortAllocator.get()
        }
        steps {
          sh 'npm run --silent -- lint --force --format=checkstyle >checkstyle-result.xml'
          // ...
      

      Job fails with

      process apparently never started in /var/lib/jenkins/node/workspace/JOBNAME@tmp/durable-eb571b59
      ...
      ERROR: script returned exit code -2

      The following is in the system log

      dockerd-current: time="2019-10-25T17:23:12.299653636+01:00" level=error msg="Error running exec in container: rpc error: code = 2 desc = oci runtime error: exec failed: container_linux.go:247: starting container process caused \"exec: \\"/var/lib/jenkins/node/caches/durable-task/durable_task_monitor_1.31_unix_64
      ": stat /var/lib/jenkins/node/caches/durable-task/durable_task_monitor_1.31_unix_64: no such file or directory\"\n"

      That file exists and is executable

      $ ls -la /var/lib/jenkins/node/caches/durable-task/
      total 2512
      drwxrwxr-x 2 jenkins jenkins    4096 Oct 25 15:26 .
      drwxrwxr-x 3 jenkins jenkins    4096 Oct 25 15:26 ..
      -rwxr-xr-x 1 jenkins jenkins 2561975 Oct 25 15:26 durable_task_monitor_1.31_unix_64
      

        Attachments

          Issue Links

            Activity

            njesper Jesper Andersson added a comment -

            This looks like the same problem as in JENKINS-59903, caused by a new binary wrapper introduced in durable-task 1.31, which is not made available inside a container.

            dnusbaum Devin Nusbaum added a comment -

            Closing as a duplicate of JENKINS-59903.


              People

              • Assignee:
                csanchez Carlos Sanchez
                Reporter:
                jameshowe James Howe
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: