Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59962

Update of durable task plugin to version 1.31 breaks ARM builds

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: durable-task-plugin
    • Labels:
    • Environment:
      Jenkins 2.190.1Ubuntu 16.04 amd64 LTS host with OpenJDK 1.8.0_222
    • Similar Issues:

      Description

      We are running the same Jenkins pipeline script on amd64 and 32/64 bit ARM build slaves, all running Ubuntu 18.04.

      The 1.31 update to the durable task plugin (from 1.30) breaks the builds on both 32 and 64 bit ARM slaves. Rolling back the version fixes the problems. The build log stops at sh

       

      [Pipeline] }
      [Pipeline] // stage
      [Pipeline] stage
      [Pipeline] { (Build arm64)
      [Pipeline] sh

        Attachments

          Activity

          carroll Carroll Chiou added a comment -

          Closing as duplicate of JENKINS-59907


            People

            • Assignee:
              Unassigned
              Reporter:
              steveoss Steve Osselton
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: