Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59969

ANSI sequences stripped from logs, no coloring

    Details

    • Similar Issues:

      Description

      Somewhere between 2.195 and 2.201, ANSI coloring broke.

       

      This doesn't seem to be a problem of the ANSI coloring plugin but of the core because ANSI sequences are stripped from the log files.

        Attachments

          Activity

          jrudolph Johannes Rudolph created issue -
          jrudolph Johannes Rudolph made changes -
          Field Original Value New Value
          Summary ANSI sequences stripped from logs ANSI sequences stripped from logs, no coloring
          jrudolph Johannes Rudolph made changes -
          Description Somewhere between 2.195 and 2.202, ANSI coloring broke.

           

          This doesn't seem to be a problem of the ANSI coloring plugin but of the core because ANSI sequences are stripped from the log files.
          Somewhere between 2.195 and 2.201, ANSI coloring broke.

           

          This doesn't seem to be a problem of the ANSI coloring plugin but of the core because ANSI sequences are stripped from the log files.
          jrudolph Johannes Rudolph added a comment -

          A bit more digging turned out that this might be caused by another change where our build software changed how it would determine if a terminal supports colors or not and disabled colors. Sorry for the noise.

          jrudolph Johannes Rudolph made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Cannot Reproduce [ 5 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              jrudolph Johannes Rudolph
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: