Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6002

Allow jobs to be grouped hierarchically

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Many jobs are related to each other. Some jobs might be grouped because they build related source:

      • they may build different branches of the same source
      • produce different artifacts
      • run in different environments.

      Or jobs may be related because they are components of a single application, like how hudson-war and hudson-test-harness and hudson-core are all part of hudson. Or jobs may be related because they are in the same business unit, or managed by the same suit.

      Hudson should support a flexible way of grouping jobs into multi-level hierarchies – that's the data part of the problem. Hudson should also provide multiple ways of viewing the hierarchy; that's the visualization part of the hierarchy.

        Attachments

          Activity

          mdonohue mdonohue added a comment -

          duplicate of JENKINS-232?

          bshine bshine added a comment -

          Not quite a duplicate of JENKINS-232 – this enhancement is calling for more sweetness. See
          http://wiki.jenkins-ci.org/display/JENKINS/Outline+View for some comments on what more we want.

          mdonohue mdonohue added a comment -

          Those are very nice looking mock ups.

          danielbeck Daniel Beck added a comment -

          Cloudbees Folders Plugin, recursive list views, numerous view-related plugins, Nested Views, Extreme Feedback panels, ...

          This issue can probably be considered resolved by using appropriate plugins.


            People

            • Assignee:
              Unassigned
              Reporter:
              bshine bshine
            • Votes:
              5 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: