Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6009

Jabber 1.7: Hudson (1.352) doesn't restart

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Component/s: jabber-plugin
    • Labels:
      None
    • Environment:
      Linux samos 2.6.28-16-server #55-Ubuntu SMP Tue Oct 20 20:37:10 UTC 2009 x86_64 GNU/Linux
    • Similar Issues:

      Description

      After upgrading Jabber (from 1.6 -> 1.7), Hudson (1.352) doesn't restart.
      The reload page is shown to browsers, but reloading doesn't terminate.
      There is no error in hudson.log.
      I have to kill -9 the JVM because soft ways don't work.
      Before upgrade, all other plugins were up to date and running well, especially instant-messaging.
      Régis

        Attachments

          Activity

          kutzi kutzi added a comment -

          Thanks for the feedback.

          You could additionally do a lsof on ww-in-f125.1e100.net (I suppose that's your Jabber server)
          and then check if any of the corresponding ports re protected by some firewall rule.

          rdesgroppes Régis Desgroppes added a comment -

          No, that's an external server (.1e100.net belongs to Google)
          $ ping gmail.com

          kutzi kutzi added a comment - - edited

          Hmm, not much ideas left how to help you.

          • have you tried to disable SASL authentication in the global config page?
          • SYN_SENT seems to incidcate that there are connection problems on the TCP level. Maybe you have some network admin at hand who can help you to debug this? This is definitely out of my knowledge field

          BTW: with Jabber plugin v1.10 Hudson does restart, right? 'Only' Jabber connection doesn't work.

          rdesgroppes Régis Desgroppes added a comment -

          Yes!

          So the problem is now solved. All what I've done:
          1. upgraded Hudson Jabber notifier plugin to 1.10 (w/ Hudson instant-messaging plugin 1.8)
          2. forced server to: talk.google.com [I didn't see this notice in the wiki page before]
          3. disabled SASL authentication

          I think we can close this issue.

          Thanks for all your inputs.
          Régis

          rdesgroppes Régis Desgroppes added a comment -

            People

            • Assignee:
              kutzi kutzi
              Reporter:
              rdesgroppes Régis Desgroppes
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: