Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60360

error occurs when 'git config --get submodule.**.url

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: git-plugin
    • Labels:
    • Environment:
      Jenkins 2.190.2
      Git Plugin 3.9.3
      Git Client Plugin 2.8.6
    • Similar Issues:

      Description

      I want to update submodule using git plugin as below.

       

      But it occurs error : 

       > git remote # timeout=10
       > git submodule init # timeout=10
       > git submodule sync # timeout=10
       > git config --get remote.origin.url # timeout=10
       > git submodule init # timeout=10
       > git config -f .gitmodules --get-regexp ^submodule\.(.+)\.url # timeout=10
       > git config --get submodule.bucketlistall.url # timeout=10
      Also:   hudson.remoting.Channel$CallSiteStackTrace: Remote call to JNLP4-connect connection from 172.30.16.22/172.30.16.22:49470
      		at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1743)
      		at hudson.remoting.UserRequest$ExceptionResponse.retrieve(UserRequest.java:357)
      		at hudson.remoting.Channel.call(Channel.java:957)
      		at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler.execute(RemoteGitImpl.java:146)
      		at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      		at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      		at java.lang.reflect.Method.invoke(Method.java:498)
      		at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler.invoke(RemoteGitImpl.java:132)
      		at com.sun.proxy.$Proxy139.execute(Unknown Source)
      		at hudson.plugins.git.extensions.impl.SubmoduleOption.onCheckoutCompleted(SubmoduleOption.java:108)
      		at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1270)
      		at hudson.scm.SCM.checkout(SCM.java:504)
      		at hudson.model.AbstractProject.checkout(AbstractProject.java:1208)
      		at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:574)
      		at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      		at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:499)
      		at hudson.model.Run.execute(Run.java:1815)
      		at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
      		at hudson.model.ResourceController.execute(ResourceController.java:97)
      		at hudson.model.Executor.run(Executor.java:429)
      hudson.plugins.git.GitException: Command "git config --get submodule.bucketlistall.url" returned status code 1:
      stdout: 
      stderr: 
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:2172)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:2140)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:2136)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommand(CliGitAPIImpl.java:1741)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommand(CliGitAPIImpl.java:1753)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getSubmoduleUrl(CliGitAPIImpl.java:1353)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$7.execute(CliGitAPIImpl.java:1279)
      	at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler$1.call(RemoteGitImpl.java:153)
      	at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler$1.call(RemoteGitImpl.java:146)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:212)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:54)
      	at hudson.remoting.Request$2.run(Request.java:369)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
      	at hudson.remoting.Engine$1.lambda$newThread$0(Engine.java:93)
      	at java.lang.Thread.run(Thread.java:748)
      Caused: java.io.IOException: Could not perform submodule update
      	at hudson.plugins.git.extensions.impl.SubmoduleOption.onCheckoutCompleted(SubmoduleOption.java:113)
      	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1270)
      	at hudson.scm.SCM.checkout(SCM.java:504)
      	at hudson.model.AbstractProject.checkout(AbstractProject.java:1208)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:574)
      	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:499)
      	at hudson.model.Run.execute(Run.java:1815)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
      	at hudson.model.ResourceController.execute(ResourceController.java:97)
      	at hudson.model.Executor.run(Executor.java:429)
      

      Why is this happen? 

        Attachments

          Activity

          markewaite Mark Waite added a comment - - edited

          I don't know why that happens. Since you did not provide enough information that anyone else could assist, I will leave this issue open for at least one day and will then close it as "cannot reproduce". If you would like to avoid this bug being closed as "cannot reproduce", please provide significantly more details to describe the problem and confirm that you have investigated the cause of the problem.

          Please provide a series of steps which someone else can use to duplicate the problem you are seeing. That might include steps like:

          1. Define a freestyle job that clones https://github.com/MarkEWaite/docker-lfs.git
          2. Add the checkout option to recursively update submoodules
          3. Run the Jenkins job

          Actual Result: Checkout fails
          Expected Result: Checkout succeeds

          wndus901 juyeon lee added a comment -
          1. Define a freestyle job that clones in-house github repository. 
          2. Add the checkout option to recursively update submodules
          3. Run the jenkins job

          That's all. it's not a problem of source code in github repository. 
          Because it works in Git-Bash. 

          markewaite Mark Waite added a comment -

          Your description is not sufficiently detailed for me to duplicate your problem. The steps you describe (without details of the contents of the submodule definitions) are the same steps I regularly use to confirm that submodule update works on multiple platforms and with multiple configurations.

          Then is something distinct in your environment that is not visible in my environment and is not included in your description of the issue. For example, it could be that you are seeing:

          • JENKINS-55875 - Jenkins submodule update fails when submodule isn't clean
          • JENKINS-43977 - Git checkout fails if submodule defined in .gitmodules don't exist
          • JENKINS-38860 - Git plugin using local config to update submodules

          If you are seeing one of those cases, please mark this issue as a duplicate and close it.

          If you are seeing something that is not one of those cases, please describe the issue in enough detail that someone else can duplicate the problem. You're trying to persuade someone like me to give their personal time to help you with your issue. Make it easier for me to help you by providing enough information that the problem can be duplicated outside the specific environment where you are seeing the issue.

          markewaite Mark Waite added a comment -

          Since I cannot duplicate the bug as described and there has been no further description in several days, I'm closing this bug as "Cannot Reproduce".

          If additional information is provided which allows it to be duplicated and it is shown to be different than the bugs linked in the previous comment, then it can be reopened with that more detailed description.


            People

            • Assignee:
              Unassigned
              Reporter:
              wndus901 juyeon lee
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: