Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60363

Include TLSv1.2 instruction in P4-Plugin Doc

    Details

    • Similar Issues:

      Description

      Include following information in Jenkins administration guide:
       
      https://community.perforce.com/s/article/2620
       
      For example it could be added to:
           https://www.perforce.com/manuals/jenkins/Content/P4Jenkins/credentials.html?Highlight=JCE#Connection_Issues
       

      Solution2: If you have configured your Helix VCS server to have a minimum TLS version greater than v1.0 you need to start Jenkins with the additional flag '-DsecureSocketEnabledProtocols=VERSION' where 'VERSION' is a comma-separated list of accepted protocol versions.
      
      For example edit  '/etc/default/jenkins' and it the falg to 'JAVA_ARGS':
            JAVA_ARGS="-Djava.awt.headless=true  -DsecureSocketEnabledProtocols=TLSv1.2"
      
      This will need to be set on the master and every build slave.

       
       
       
       
       

        Attachments

          Issue Links

            Activity

            Hide
            p4kevin Kevin Williamson added a comment -

            Doc update complete and waiting for release. 

            Show
            p4kevin Kevin Williamson added a comment - Doc update complete and waiting for release. 
            Hide
            p4kevin Kevin Williamson added a comment -

            Doc update released

            Show
            p4kevin Kevin Williamson added a comment - Doc update released

              People

              • Assignee:
                p4kevin Kevin Williamson
                Reporter:
                p4karl Karl Wirth
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: