Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60395

ALM jenkins plugin: ALM results upload issue

    Details

    • Similar Issues:

      Description

      Hello we're using Micro Focus Application Automation Tools: 5.9 jenkins "upload test results to ALM" plugin and it seems if we start one job that runs long, and we start a new separate job while the first is still running the plugin will not upload the results on the second job when it finishes until the first job completes, getting a message
      "Upload test result to ALM is waiting for a checkpoint on Test Automation » XXXX"
      So it seems the is an odd dependency on what should be separate jenkins runs. We have the ALM upload as the last step, yet it seems to block other connections outside of its run right when it starts

        Attachments

          Activity

          Hide
          roy_lu Roy Lu added a comment -

          Could you please send me the console output of the 1st and 2nd job by email?

          Show
          roy_lu Roy Lu added a comment - Could you please send me the console output of the 1st and 2nd job by email?
          Hide
          poberly Paul Oberly added a comment -

          Files added (on my customer's behalf), thing to look for in the short run console is

          "Upload test result to ALM is waiting for a checkpoint on Test Automation � Test Automation - GUI #605: "

          #605 is the first long running job

          each job runs a different VM (UFTRT001 vs UFTRT002)

          Show
          poberly Paul Oberly added a comment - Files added (on my customer's behalf), thing to look for in the short run console is "Upload test result to ALM is waiting for a checkpoint on Test Automation � Test Automation - GUI #605: " #605 is the first long running job each job runs a different VM (UFTRT001 vs UFTRT002)
          Hide
          jmyates86 Joshua Yates added a comment -

          Any update on this?

          Show
          jmyates86 Joshua Yates added a comment - Any update on this?
          Hide
          poberly Paul Oberly added a comment -

          PLEASE, any updates on this?

          Show
          poberly Paul Oberly added a comment - PLEASE, any updates on this?
          Hide
          roy_lu Roy Lu added a comment -

          Hi Rolando-Mihai Vlad,

          Please advise, is this related to https://issues.jenkins-ci.org/browse/JENKINS-60514 ?

          I see many changes in your commit. Which is the real change that make it concurrent?

          Show
          roy_lu Roy Lu added a comment - Hi Rolando-Mihai Vlad , Please advise, is this related to https://issues.jenkins-ci.org/browse/JENKINS-60514  ? I see many changes in your commit. Which is the real change that make it concurrent?
          Hide
          rolandomihaivlad Rolando-Mihai Vlad added a comment - - edited
          Show
          rolandomihaivlad Rolando-Mihai Vlad added a comment - - edited https://github.com/jenkinsci/hpe-application-automation-tools-plugin/commit/d512c67b431ccb9b3660dfb0b7d4393aefb66393  line 1455 allows the build to be concurrent (BuildStepMonitor.NONE).

            People

            • Assignee:
              roy_lu Roy Lu
              Reporter:
              poberly Paul Oberly
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: