Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60426

All stages show up as UNSTABLE when one stage is unstable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      Jenkins 2.176.3, Pipeline Stage View Plugin 2.12
    • Similar Issues:

      Description

      In the classical GUI all stages are shown as unstable when only one stage is (in BlueOcean it is displayed correct)

      My expectation: Only the unstable stage is displayed as unstable, others are not (while the complete build still is marked as unstable)

       

       

      #!groovy
      
      pipeline {   
      
          agent any
      
          stages {
              stage('successful') {
                  steps {
                      echo ('hello')
                  }
              }
              
              stage('unstable') {
                  steps {
                      unstable(message: "Failed: ${STAGE_NAME} => return UNSTABLE status")
                  }
              }
          }
      }
      
      

       

      Potentially related to JENKINS-39203

        Attachments

          Issue Links

            Activity

            nickbrown Nicholas Brown added a comment - - edited
            chrop Christian Opitz added a comment - - edited

            Yes, seems to be a duplicate of the one mentioned. Closing this one.


              People

              • Assignee:
                svanoort Sam Van Oort
                Reporter:
                chrop Christian Opitz
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: