Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60622

Provide option for Javac parser to ignore errorprone warnings/errors

    Details

    • Similar Issues:

      Description

      This commit stopped errorprone errors/warnings being recognised by the Warnings Next Generation plugin - I don't understand why anyone would want this behavior (if you don't want to see errorprone warnings, don't use it) but if it must be kept I think it should be a flag which can be optionally disabled.

      If the regex in edu.hm.hafner.analysis.parser.JavacParser were changed to remove the trailing $ it would then match multi-line errorprone errors if passed directly, but if passed the lines individually would continue to work as expected in the previous version.

        Attachments

          Activity

          jfreedman Jon Freedman created issue -
          drulli Ulli Hafner made changes -
          Field Original Value New Value
          Summary Javac parser ignores errorprone warnings/errors Provide option for Javac parser to ignore errorprone warnings/errors
          Issue Type Story [ 10002 ] Improvement [ 4 ]
          Component/s warnings-ng-plugin [ 24526 ]
          Labels help-wanted
          Assignee Ulli Hafner [ drulli ]
          drulli Ulli Hafner made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Won't Fix [ 2 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              jfreedman Jon Freedman
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: