Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60648

java.lang.IllegalStateException: The super POM /org/apache/maven/model/pom-4.0.0.xml was not found, please verify the integrity of your Maven installation

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Environment:
      Openjdk 1.8.0_222
      Jenkins 2.112
      Apache Maven 3.5.2 and 3.6.3
      Linux ip-10-0-1-57 4.14.154-99.181.amzn1.x86_64 #1 SMP Sat Nov 16 01:38:34 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
    • Similar Issues:
    • Released As:
      2.213

      Description

       

      Jenkins 2.112 does not build our maven builds. Rollback to 2.111 fixed this. Update of apache maven did not help.

      Creating a ticket as the error says, search did not find anything:
      Running as SYSTEM
      [EnvInject] - Loading node environment variables.
      Building in workspace /mnt/storage/jenkins/workspace/guide.portal - Integration
      No credentials specified
      > git rev-parse --is-inside-work-tree # timeout=10
      Fetching changes from the remote Git repository
      > git config remote.origin.url git@bitbucket.org:corussoft/guide.portal.git # timeout=10
      Fetching upstream changes from git@bitbucket.org:corussoft/guide.portal.git
      > git --version # timeout=10
      > git fetch --tags --progress – git@bitbucket.org:corussoft/guide.portal.git +refs/heads/:refs/remotes/origin/ # timeout=10
      > git rev-parse refs/remotes/origin/integration^{commit} # timeout=10
      > git rev-parse refs/remotes/origin/origin/integration^{commit} # timeout=10
      Checking out Revision c9483f7765f95bf4fe532c3311197e6cd370dff6 (refs/remotes/origin/integration)
      > git config core.sparsecheckout # timeout=10
      > git checkout -f c9483f7765f95bf4fe532c3311197e6cd370dff6 # timeout=10
      Commit message: "- speichern: schedulingPattern, start und end des Importers geht nun"
      > git rev-list --no-walk c9483f7765f95bf4fe532c3311197e6cd370dff6 # timeout=10
      Parsing POMs
      ERROR: Processing failed due to a bug in the code. Please report this to the issue tracker (
      https://jenkins.io/redirect/report-an-issue
      ).
      java.lang.IllegalStateException: The super POM /org/apache/maven/model/pom-4.0.0.xml was not found, please verify the integrity of your Maven installation
      at org.apache.maven.model.superpom.DefaultSuperPomProvider.getSuperModel(DefaultSuperPomProvider.java:67)
      at org.apache.maven.model.building.DefaultModelBuilder.getSuperModel(DefaultModelBuilder.java:1132)
      at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:282)
      at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:432)
      at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:400)
      at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:363)
      at hudson.maven.MavenEmbedder.buildProjects(MavenEmbedder.java:370)
      at hudson.maven.MavenEmbedder.readProjects(MavenEmbedder.java:340)
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1329)
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1126)
      at hudson.FilePath.act(FilePath.java:1075)
      at hudson.FilePath.act(FilePath.java:1058)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.parsePoms(MavenModuleSetBuild.java:987)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:691)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
      at hudson.model.Run.execute(Run.java:1853)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
      at hudson.model.ResourceController.execute(ResourceController.java:97)
      at hudson.model.Executor.run(Executor.java:428)
      project=hudson.maven.MavenModuleSet@69f2acd3[guide.portal - Integration]
      project.getModules()=[hudson.maven.MavenModule@11866abd[guide.portal - Integration/de.corussoft:guide.portal][guide.portal - Integration/de.corussoft:guide.portal][relativePath:]]
      project.getRootModule()=hudson.maven.MavenModule@11866abd[guide.portal - Integration/de.corussoft:guide.portal][guide.portal - Integration/de.corussoft:guide.portal][relativePath:]
      FATAL: The super POM /org/apache/maven/model/pom-4.0.0.xml was not found, please verify the integrity of your Maven installation
      java.lang.IllegalStateException: The super POM /org/apache/maven/model/pom-4.0.0.xml was not found, please verify the integrity of your Maven installation
      at org.apache.maven.model.superpom.DefaultSuperPomProvider.getSuperModel(DefaultSuperPomProvider.java:67)
      at org.apache.maven.model.building.DefaultModelBuilder.getSuperModel(DefaultModelBuilder.java:1132)
      at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:282)
      at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:432)
      at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:400)
      at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:363)
      at hudson.maven.MavenEmbedder.buildProjects(MavenEmbedder.java:370)
      at hudson.maven.MavenEmbedder.readProjects(MavenEmbedder.java:340)
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1329)
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1126)
      at hudson.FilePath.act(FilePath.java:1075)
      at hudson.FilePath.act(FilePath.java:1058)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.parsePoms(MavenModuleSetBuild.java:987)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:691)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
      at hudson.model.Run.execute(Run.java:1853)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
      at hudson.model.ResourceController.execute(ResourceController.java:97)
      at hudson.model.Executor.run(Executor.java:428)

        Attachments

          Issue Links

            Activity

            ckirschner Carsten Kirschner created issue -
            harikavegesna harika vegesna made changes -
            Field Original Value New Value
            Priority Major [ 3 ] Blocker [ 1 ]
            harikavegesna harika vegesna added a comment - - edited

            Even i face the same issue .Till yesterday it's working fine
            ERROR: Processing failed due to a bug in the code. Please report this to the issue tracker (
            https://jenkins.io/redirect/report-an-issue
            ).
            java.lang.IllegalStateException: The super POM /org/apache/maven/model/pom-4.0.0.xml was not found, please verify the integrity of your Maven installation
            at org.apache.maven.model.superpom.DefaultSuperPomProvider.getSuperModel(DefaultSuperPomProvider.java:67)
            at org.apache.maven.model.building.DefaultModelBuilder.getSuperModel(DefaultModelBuilder.java:1132)
            at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:282)
            at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:432)
            at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:400)
            at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:363)
            at hudson.maven.MavenEmbedder.buildProjects(MavenEmbedder.java:370)
            at hudson.maven.MavenEmbedder.readProjects(MavenEmbedder.java:340)
            at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1329)
            at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1126)
            at hudson.FilePath.act(FilePath.java:1075)
            at hudson.FilePath.act(FilePath.java:1058)
            at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.parsePoms(MavenModuleSetBuild.java:987)
            at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:691)
            at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
            at hudson.model.Run.execute(Run.java:1853)
            at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
            at hudson.model.ResourceController.execute(ResourceController.java:97)
            at hudson.model.Executor.run(Executor.java:428)
            project=hudson.maven.MavenModuleSet@74dc6e22[BLNQAAutomation]
            project.getModules()=

            harikavegesna harika vegesna made changes -
            Labels jenkins
            oleg_nenashev Oleg Nenashev added a comment -

            Please try again with 2.213. From what I see it is just another symptom of the resource loading bug we fixed

            ckirschner Carsten Kirschner added a comment -

            Thanks for the quick release

            ckirschner Carsten Kirschner made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            Released As 2.213
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue duplicates JENKINS-60644 [ JENKINS-60644 ]
            oleg_nenashev Oleg Nenashev made changes -
            Labels jenkins jenkins regression

              People

              • Assignee:
                Unassigned
                Reporter:
                ckirschner Carsten Kirschner
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: