Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61154

Pipeline: Groovy 2.79 does not abort the build if a pipeline stage fails

    Details

    • Type: Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: workflow-cps-plugin
    • Environment:
    • Similar Issues:

      Description

      Since upgrading to workflow-cps 2.79, our scripted pipelines do not abort if a single stage fails. Rolling back to 2.78 fixes the issue.

        Attachments

          Activity

          wreimers Liam Reimers added a comment -

          Cannot reproduce with 2.80.


            People

            • Assignee:
              Unassigned
              Reporter:
              wreimers Liam Reimers
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: