Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61217

Stage view for previous builds should not be removed if stages change

    Details

    • Similar Issues:

      Description

      If the stages for the last build were modified (added/renamed/removed) then all stage view history for the previous builds is removed. I don't like this behavior. It is not convenient, because often I need view logs for a certain stage of a certain previous build (even if such a stage does not exist in the current build anymore).

      If the stages for last build don't correspond to the stages of the previous builds it is not a reason to remove the previous ones. It is still possible to display stages for each build independently. It is not a problem if a certain stage is displayed on different positions in different builds. The bigger problem is if it is not available at all like now.

      My proposal is to keep stages for previous builds even if they are different. That is, the stage view history should be not just a matrix, but an ordered list of ordered lists with different size.

      Vizualisazion?
      Each row can be simply independently rendered (the rows can have different length).
      It is possible also to "merge" it and display blank rectangles for whose builds who don't have a certain stage, but it is probably more complicated.

        Attachments

          Issue Links

            Activity

            ataylor Alex Taylor added a comment -

            Reclassified as a new feature because this is behaving as designed and will require a significant amount of work

            ankurja Ankur added a comment -

            I face same issue. Created this issue but closed as duplicate after seeing this one. Stage rows from previous builds should still be shown.

            I noticed that when a new stage is added at the end of existing stages then it works as expected. All previous build stages continue to show with the new stage as blank. The behavior should remain same when new stage is added in middle of existing stages.


              People

              • Assignee:
                svanoort Sam Van Oort
                Reporter:
                alexander_samoylov Alexander Samoylov
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: