Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6126

ERROR: Failed to record SCM polling nullpointer exception when building on a slave while the number of executors on the master is set to 0

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: mercurial-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 9.10 Slave

      Description

      I have my mercurial build setup on a ubuntu slave, and get the following in polling log if the number of executors on the master is set to 0.

      ERROR: Failed to record SCM polling
      java.lang.NullPointerException
      at hudson.model.Run.getEnvironment(Run.java:1648)
      at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:663)
      at hudson.plugins.mercurial.MercurialSCM.compareRemoteRevisionWith(MercurialSCM.java:250)
      at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:351)
      at hudson.scm.SCM.poll(SCM.java:368)
      at hudson.model.AbstractProject.poll(AbstractProject.java:1153)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:330)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:359)
      at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)

        Issue Links

          Activity

          dhavalshah dhavalshah added a comment -

          this also happens on a windows slave. hudson build is 1.352

          mfriedenhagen Mirko Friedenhagen added a comment -

          Hello,

          could you provide more info, e.g. did you configure Merurial in your master config or is the hg executable in your path, did the setup?
          What version of the plugin are you using?

          Regards
          Mirko

          dhavalshah dhavalshah added a comment - - edited

          I have the version 1.353 of hudson, and 1.28 of mercurial plug-in. i did not have mercurial installed on my master hudson machine, but it was installed on the slave. I did install mercurial on the master, and still got the same error.

          mfriedenhagen Mirko Friedenhagen added a comment -

          After examing the stacktrace a bit I think this is maybe not a bug in the plugin but in the core, this is the throwing line:

          EnvVars env = Computer.currentComputer().getEnvironment().overrideAll(getCharacteristicEnvVars());

          Unfortunately there is a bit of daisychaining in this line, so I do not know why this throws a NPE.

          Could you try to build on the master?
          What locale are the master and the slave running with?
          Do you maybe have an unusual name for the slave (with spaces etc.)?
          Is this the first run of the job or has the plugin worked for you before?
          What version of Java are you running on master and slave?

          I am just guessing right here.

          Regards
          Mirko

          dhavalshah dhavalshah added a comment - - edited

          Hi Mirko,

          1) both master and slave are on en-us
          2) the slave doesn't have an unusual name. the name is hudsoncont
          3) we just made the switch to mercurial, so, not sure if the plug-in was working before. it has not worked ever since we started using it.
          4) we are using JDK 1.6.0_18

          i will also try to do the build on master to see if it goes through.

          -Dhaval

          mfriedenhagen Mirko Friedenhagen added a comment - - edited

          Sorry for querying again:

          • Does any of your changesets contain a non-ASCII letter?
          • Do you use Maven2 or Freestyle build?
          • I just created a new job http://s312195779.online.de/hudson/job/HgKit-FS/1/console which worked fine for me.
          • How do you access your Mercurial repository (http, ssh, direct file access via NFS)?

          Regards
          Mirko

          dhavalshah dhavalshah added a comment - - edited

          Hi Mirko,

          first of all, i just wanted to thank you for looking into this issue for me.

          • as far as i know, none of the files have non-ascii characters
          • we are using freestyle projects
          • i get the error while polling, and on your build, i just get "polling has not occured yet". what is your poll interval? mine is set to poll every 15 mins.
          • our mercurial repository is accessed over https (with self signed certificates)

          also, isn't the error getting thrown even before trying to access the repository?

          Thanks,
          Dhaval

          mfriedenhagen Mirko Friedenhagen added a comment - - edited

          Hm, I now recreated the aforementioned job and get http://s312195779.online.de/hudson/job/HgKit-FS/1/console
          I did set polling the SCM to every minute, seems to work fine.
          Could you try to configure a FS job with http://hg.berlios.de/repos/hgkit as the URL of the mercurial repository? Maybe there is a problem with self signed certificates?
          Did you configure any mercurial extensions?
          Do any of the comments on changesets contain non ASCII letters?
          BTW, my locale is set to en_US.UTF-8, is en-us valid?
          Regards
          Mirko

          dhavalshah dhavalshah added a comment - - edited

          Hi Mirko,
          i got the same null pointer exception with your repo.

          • i am using JDK 1.6.0_18
          • all of our comments are in english, and do not have any non-ascii characters.
          • my locale is also en-us.

          -Dhaval

          mfriedenhagen Mirko Friedenhagen added a comment -

          Could you set up a Freestyle job without SCM having as first build step a shell script with the following content:

          hg clone --rev default http://hg.berlios.de/repos/hgkit ${WORKSPACE}
          hg log --rev . --template {node}
          hg incoming --quiet --bundle hg.bundle --template "<changeset node='{node}' author='{author|xmlescape}' rev='{rev}' date='{date}'><msg>{desc|xmlescape}</msg><added>{file_adds|stringify|xmlescape}</added><deleted>{file_dels|stringify|xmlescape}</deleted><files>{files|stringify|xmlescape}</files><parents>{parents}</parents></changeset>\n" --rev default
          hg log --rev . --template {node}
          

          These are the steps executed by the mercurial plugin, maybe we see more information in the console log.
          Are you running hudson with the embedded winstone container or in another one (Tomcat, Jetty)?

          Regards
          Mirko

          dhavalshah dhavalshah added a comment -

          that build also failed. here is the output from my console

          Started by user dhaval
          Building remotely on ubuntu-slave
          [mercurialBugTest] $ sh -xe /tmp/hudson280390980807523999.sh
          + hg clone --rev default http://hg.berlios.de/repos/hgkit /opt/hudson/workspace/mercurialBugTest
          requesting all changes
          adding changesets
          adding manifests
          adding file changes
          added 279 changesets with 717 changes to 138 files
          updating to branch default
          60 files updated, 0 files merged, 0 files removed, 0 files unresolved
          + hg log --rev . --template {node}
          a2289e843124943a8033733845a2eff7f6ec4c2b+ hg incoming --quiet --bundle hg.bundle --template <changeset node='{node}' author='{author|xmlescape}' rev='{rev}' date='{date}'><msg>{desc|xmlescape}</msg><added>{file_adds|stringify|xmlescape}</added><deleted>{file_dels|stringify|xmlescape}</deleted><files>{files|stringify|xmlescape}</files><parents>{parents}</parents></changeset>\n --rev default
          Finished: FAILURE
          
          mfriedenhagen Mirko Friedenhagen added a comment - - edited

          Hm, which version of Mercurial are you running? (Try hg --version). Newer versions for Ubuntu might be available as package at http://www.backports.org/dokuwiki/doku.php.

          And you could try to replace the --quiet option with --verbose on the incoming command.

          Could you try to insert:

          export LANG=en_US.UTF-8
          export LC_ALL=en_US.UTF-8
          

          before invoking hg?

          dhavalshah dhavalshah added a comment -

          Here is the output:

          Started by user dhaval Building remotely on ubuntu-slave [mercurialbug] $ sh -xe /tmp/hudson5644486299255947626.sh
          + export LANG=en_US.UTF-8 + export LC_ALL=en_US.UTF-8 + hg clone --rev default http://hg.berlios.de/repos/hgkit /opt/hudson/workspace/mercurialbug
          requesting all changes adding changesets adding manifests adding file changes added 279 changesets with 717 changes to 138 files updating to branch default 60 files updated, 0 files merged, 0 files removed, 0 files unresolved + hg log --rev . --template {node} a2289e843124943a8033733845a2eff7f6ec4c2b+ hg incoming --verbose --bundle hg.bundle --template <changeset node='{node}' author='{author|xmlescape}' rev='{rev}' date='{date}'><msg>{desc|xmlescape}</msg><added>{file_adds|stringify|xmlescape}</added><deleted>{file_dels|stringify|xmlescape}</deleted><files>{files|stringify|xmlescape}</files><parents>{parents}</parents></changeset>\n --rev default
          comparing with http://hg.berlios.de/repos/hgkit searching for changes no changes found
          Finished: FAILURE 
          

          I have tried with both 1.4.3 and 1.5.1 with the same results. can it be the jdk i'm using? what jdk were you using for your build?

          dhavalshah dhavalshah added a comment - - edited

          Hi Mirko,

          I found what is causing the null pointer exception. the exception is caused when the number of executors on the master machine is set to 0. (in our setup, we have a master "dashboard" and a bunch of remote slaves to execute builds) we set the number of executors to 0, because we don't want people to run builds on the master.

          mfriedenhagen Mirko Friedenhagen added a comment -

          Well, that explains it .
          Is it OK for you if I close the issue, then?

          Regards
          Mirko

          dhavalshah dhavalshah added a comment -

          Hi Mirko,

          isn't this still a bug? why do you need a executor on the master when the builds are acutally going to happen on the slave? we also use subversion/clearcase connectors, and they were working fine without the executor on master.

          mfriedenhagen Mirko Friedenhagen added a comment -

          Reopened as no executors should be needed on the master if builds only happen on slaves.

          mfriedenhagen Mirko Friedenhagen added a comment -

          Hello,

          could you try to reduce the number of executors to 0 again on the master after the initial checkout was successful, so we can eventually boil down the problem a bit?

          Regards
          Mirko

          dhavalshah dhavalshah added a comment -

          as soon as change the number of executors back to 0, the null pointer returns.

          -Dhaval

          stefanbrausch Stefan Brausch added a comment -

          Same issue with the GIT-Plugin 1.1 on Hudson 1.376:
          Started on Oct 13, 2010 6:09:30 PM
          Using strategy: Default
          [poll] Last Build : #1475
          [poll] Last Built Revision: Revision f71aa68147de29a707e2cc2075b97648ff501612
          ERROR: Failed to record SCM polling
          java.lang.NullPointerException
          at hudson.model.Run.getEnvironment(Run.java:1673)
          at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:682)
          at hudson.plugins.git.GitSCM.pollChanges(GitSCM.java:420)
          at hudson.scm.SCM.poll(SCM.java:369)
          at hudson.model.AbstractProject.poll(AbstractProject.java:1195)
          at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:355)
          at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:384)
          at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
          at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
          at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
          at java.util.concurrent.FutureTask.run(FutureTask.java:138)
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
          at java.lang.Thread.run(Thread.java:619)

          recampbell recampbell added a comment -

          We are also seeing this issue with a master that has no executors. I believe it's due to this change:

          http://fisheye.jenkins-ci.org/changelog/Hudson?cs=26453

          Perhaps hudson.model.Run.getEnvironment(TaskListener) should do a null check on the call to Computer.currentComputer() to handle the case where the build is not running?

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/plugins/mercurial/src/main/java/hudson/plugins/mercurial/MercurialSCM.java
          trunk/hudson/plugins/mercurial/src/main/java/hudson/plugins/mercurial/MercurialTagAction.java
          http://jenkins-ci.org/commit/36945
          Log:
          [FIXED JENKINS-6126] It doesn't make sense to call Build.getEnvironment() if the build isn't in progress.
          The polling should compare revisions in the context of the same branch.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/plugins/mercurial/src/main/java/hudson/plugins/mercurial/MercurialSCM.java
          trunk/hudson/plugins/mercurial/src/main/java/hudson/plugins/mercurial/MercurialTagAction.java
          trunk/hudson/plugins/mercurial/src/test/java/hudson/plugins/mercurial/MercurialSCMTest.java
          http://jenkins-ci.org/commit/36951
          Log:
          [FIXED JENKINS-6126] If the SCM configuration is changed and point to a different branch, then the polling should honor that. In that sense using MercurialSCM.branch is correct.


            People

            • Assignee:
              mfriedenhagen Mirko Friedenhagen
              Reporter:
              dhavalshah dhavalshah
            • Votes:
              5 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: