Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62065

The bread crumb navigation on the top of the job is not responding after clicking Apply

    Details

    • Similar Issues:
    • Released As:
      Jenkins 2.235

      Description

      After clicking the Apply to save the job configuration the the top breadcrumb navigation that allows editing and moving to the parent view is no longer functional. When clicking on it nothing happens. This started happening after may be 2.226 

        Attachments

          Issue Links

            Activity

            Hide
            danielbeck Daniel Beck added a comment - - edited

            This started happening after may be 2.226

            2.230 actually. It still works on 2.229.

            Show
            danielbeck Daniel Beck added a comment - - edited This started happening after may be 2.226 2.230 actually. It still works on 2.229.
            Hide
            danielbeck Daniel Beck added a comment -
            Show
            danielbeck Daniel Beck added a comment - Romen Rodriguez-Gil FYI
            Hide
            romenrg Romen Rodriguez-Gil added a comment -

            Just tested it locally and it seems this only happens if the user has scrolled. Going back to the top of the page the breadcrumb links are clickable.

            Doing some further research, I discovered the issue. The notification-bar div has opacity 0 but it is still being displayed and, when moved down, that div is located right above the breadcrumb, preventing clicks. I'm working on a fix, to set display to "none" when the alert disappears.

            Show
            romenrg Romen Rodriguez-Gil added a comment - Just tested it locally and it seems this only happens if the user has scrolled. Going back to the top of the page the breadcrumb links are clickable. Doing some further research, I discovered the issue. The notification-bar div has opacity 0 but it is still being displayed and, when moved down, that div is located right above the breadcrumb, preventing clicks. I'm working on a fix, to set display to "none" when the alert disappears.
            Hide
            romenrg Romen Rodriguez-Gil added a comment -

            This bug has been addressed in the following PR: https://github.com/jenkinsci/jenkins/pull/4696

            Show
            romenrg Romen Rodriguez-Gil added a comment - This bug has been addressed in the following PR:  https://github.com/jenkinsci/jenkins/pull/4696

              People

              • Assignee:
                romenrg Romen Rodriguez-Gil
                Reporter:
                sgabriel Samuel Gabriel
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: