Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
      None
    • Environment:
      OS X 10.6.3, JDK 1.6.0_17
    • Similar Issues:
      Show 5 results

      Description

      testSymlink fails with the following:

        <testcase time="1.04" classname="hudson.UtilTest" name="testSymlink">
          <error message="Failed to readlink /var/folders/HH/HHNxVzWsHDi2dNFJPBctrk+++TM/-Tmp-/hudson2878407350003022763tmp/x error=2" type="java.io.IOException">java.io.IOException: Failed to readlink /var/folders/HH/HHNxVzWsHDi2dNFJPBctrk+++TM/-Tmp-/hudson2878407350003022763tmp/x error=2
      	at hudson.Util.resolveSymlink(Util.java:1030)
      	at hudson.UtilTest.testSymlink(UtilTest.java:176)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at junit.framework.TestCase.runTest(TestCase.java:168)
      	at junit.framework.TestCase.runBare(TestCase.java:134)
      	at junit.framework.TestResult$1.protect(TestResult.java:110)
      	at junit.framework.TestResult.runProtected(TestResult.java:128)
      	at junit.framework.TestResult.run(TestResult.java:113)
      	at junit.framework.TestCase.run(TestCase.java:124)
      	at junit.framework.TestSuite.runTest(TestSuite.java:232)
      	at junit.framework.TestSuite.run(TestSuite.java:227)
      	at org.junit.internal.runners.OldTestClassRunner.run(OldTestClassRunner.java:76)
      	at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:62)
      	at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(AbstractDirectoryTestSuite.java:140)
      	at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(AbstractDirectoryTestSuite.java:127)
      	at org.apache.maven.surefire.Surefire.run(Surefire.java:177)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:345)
      	at org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:1009)
      </error>
          <system-err>log output: ln -s 48495...longNumbers...556574849505152535455 /var/folders/HH/HHNxVzWsHDi2dNFJPBctrk+++TM/-Tmp-/hudson2878407350003022763tmp/x failed: 63
      
      </system-err>
        </testcase>
      

      This seems to be because readlink on OS X doesn't suppor the -f flag.

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          error code 2 is ENOENT "no such file or directory"

          mindless Alan Harder added a comment -

          this test worked for me as of yesterday when I committed the (char) fix.. since your output above has all 48-57 values, maybe you need to svn up.

          kohsuke Kohsuke Kawaguchi added a comment -

          The root cause is that the symlink creation is failing. createsSymLink should throw an exception upon a failure.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/main/core/src/main/java/hudson/Util.java
          http://jenkins-ci.org/commit/30074
          Log:
          JENKINS-6259 report the error messaeg in addition to error code.

          mindless Alan Harder added a comment -

          above commit caused JENKINS-6437, but I've fixed that.

          back to this issue... abayer, can we close it?

          abayer Andrew Bayer added a comment -

          Yeah, this one's just weird and I'm not gonna dig into it any further for now.


            People

            • Assignee:
              Unassigned
              Reporter:
              abayer Andrew Bayer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: