Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62784

Error loading Pipeline - blueocean plugin can not edit the pipeline jenkinsfile

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Critical
    • Resolution: Unresolved
    • Labels:
    • Environment:
      Jenkins version: Jenkins 2.235.1
      Blue Ocean/Blue Ocean Pipeline Editor: 1.23.2
      java: 1.8.0_92-2
      Linux version 4.4.176-3.***.x86_64, centos7

    • Similar Issues:

      Description

      hi experts,

      After I upgrade jenkins from ver. 2.222.3 to 2.235.1 and the blue ocean related plugins from 1.23.2 to 1.23.2, the below error message pop up when i opened blue ocean, then edited:

      "There was an error loading the pipeline from the Jenkinsfile in this repository. Correct the error by editing the Jenkinsfile using the declarative syntax then commit it back to the repository."

      In fact, the Jenkinsfile is really declarative syntax. They worked well before upgrade. And now only the edit function failed.  I tried to downgrade to old version, no help. One more thing, I am not sure if i am trying to edit them during upgrade. 

      Could  you please give some hints here? Thanks.

        Attachments

          Activity

          Hide
          pustelni Konrad Pustenik added a comment -

          Any update here??

          I have the same issue...

          Show
          pustelni Konrad Pustenik added a comment - Any update here?? I have the same issue...

            People

            • Assignee:
              Unassigned
              Reporter:
              meih mei han
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: