Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63519

Git tool chooser chose the wrong implementation

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.235.5
      git plugin 4.4.0 with git tool chooser/performance improvements enabled
    • Similar Issues:
    • Released As:
      git plugin 4.4.2

      Description

      I defined a git tool installer called "portable-git-2.28.0" to install Portable Git for Windows automatically onto Windows agents. I confirmed that the tool installer works as expected and is used when I clone with performance enhancements disabled.

      When I enable performance enhancements, the repository size correctly hints that JGit should not be used. Unfortunately, instead of selecting the named git implementation that the job defines, it selects the implementation named "git".

      In my case, that selection is not a serious issue, since the implementation named "git" is the default command line git installed on the agent.

      I expected that it would select portable-git-2.28.0 as the git tool because that is the git tool that was defined for the job. I was assuming that if JGit is not selected, then the git tool defined in the job should be the preferred implementation.

      Issue is visible in the /job/Tools/job/git-portable-for-windows/ job on my computer.

        Attachments

          Issue Links

            Activity

            krachynski Ken Rachynski added a comment -

            Also worth noting that Node-/Agent-specific overrides to the default configuration get bypassed as well with performance enhancements enabled.

            markewaite Mark Waite added a comment -

            A fix is in progress in PR-949. We'd love to have additional testing to confirm that the fix handles all the cases where issues are being encountered. I've uploaded a pre-release build as git-4.4.2-rc4027.193b7e5f6521.hpi . If your installation allows it, could you confirm that it resolves the issue you're seeing? If you encounter any problems with that pre-release build, please report them in PR-949.

            markewaite Mark Waite added a comment -

            Fix released in git plugin 4.4.2 Thanks Rishabh Budhouliya!


              People

              • Assignee:
                rishabhbudhouliya Rishabh Budhouliya
                Reporter:
                markewaite Mark Waite
              • Votes:
                2 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: