Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6390

CLONE -org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: backup-plugin
    • Labels:
      None
    • Environment:
      RHEL 64 bit
    • Similar Issues:

      Description

      Hudson version: 1.348
      Hudson executed via: nohup $JAVA -Dhudson.model.Run.ArtifactList.listCutoff=24 -jar $HUDSON_WAR --httpPort=8008 >$HUDSON_LOG 2>&1 &
      Backup plugin version: 1.4.1

      [ INFO] Backup started at [03/17/10 12:08:43]
      [ INFO] Setting hudson in shutdown mode to avoid files corruptions.
      [ INFO] Waiting all jobs end...
      [ INFO] Number of running jobs detected : 0
      [ INFO] All jobs finished.
      [ INFO] Full backup file name : /home/tk694h/hudson/backup_20100317_1208.zip
      [ERROR] org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes for: /home/tk694h/.hudson/jobs/AS-10.3-Tibco-ActivityLog/scm-polling.log
      org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: Unable to add jobs/AS-10.3-Tibco-ActivityLog/scm-polling.log
      at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115)
      at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:125)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.io.IOException: Unable to add jobs/AS-10.3-Tibco-ActivityLog/scm-polling.log
      at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleFile(BackupEngine.java:90)
      at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367)
      at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
      at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
      at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335)
      at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113)
      ... 2 more
      [ INFO] Cancel hudson shutdown mode
      [ INFO] Backup end at [03/17/10 12:08:48]
      [ INFO] [5.004s]

        Attachments

          Issue Links

            Activity

            dougborg Doug Borg added a comment -

            I am running into the same issue on CentOS 5.2, Hudson 1.384 and Backup Plugin version 1.6:

            [ERROR] org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes for: /home/hudson/data/jobs/Search Fulfillments/config-history/2010-11-15_19-00-06/config.xml
            org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: Unable to add jobs/Search Fulfillments/config-history/2010-11-15_19-00-06/config.xml
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115)
            at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:130)
            at java.lang.Thread.run(Thread.java:662)
            Caused by: java.io.IOException: Unable to add jobs/Search Fulfillments/config-history/2010-11-15_19-00-06/config.xml
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleFile(BackupEngine.java:90)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335)
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113)
            ... 2 more
            [ INFO] Cancel hudson shutdown mode
            [ INFO] Backup end at [12/30/10 13:26:49]
            [ INFO] [5.635s]

            dougborg Doug Borg added a comment -

            These to issues seem to have the same root cause.

            rseguy Romain Seguy added a comment -

            Duplicates JENKINS-5968


              People

              • Assignee:
                Unassigned
                Reporter:
                tomaszkow tomaszkow
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: