Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6421

EMail-Notifiers in multi-module projects are ignored

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: mailer-plugin
    • Labels:
      None
    • Environment:
      Linux RHEL5 / Tomcat 5.5
    • Similar Issues:

      Description

      We have a multi-module job. Mail-Notifiers in module POMs are defined as follows:

      <ciManagement>
      <system>hudson</system>
      <url>https://server/hudson/</url>
      <notifiers>
      <notifier>
      <type>mail</type>
      <sendOnError>true</sendOnError>
      <sendOnFailure>true</sendOnFailure>
      <sendOnSuccess>false</sendOnSuccess>
      <sendOnWarning>false</sendOnWarning>
      <configuration>
      <recipients>a.b@c.de</recipients>
      </configuration>
      </notifier>
      </notifiers>
      </ciManagement>

      These do not work properly. As far as I understood the system the email-entries in module configurations are modified automatically (see attachements). This seems to work initially. But when notifiers-entries in module-POMs are defined later on they will be ignored. Therefore no email-notifications are sent and our developers cannot fix the problem...

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Marcelo Rebasti
            Path:
            src/main/java/hudson/maven/MavenModule.java
            src/main/java/hudson/maven/MavenModuleSetBuild.java
            src/main/java/hudson/maven/reporters/MavenMailer.java
            src/test/java/hudson/maven/MavenModuleTest.java
            src/test/java/hudson/maven/reporters/MavenMailerTest.java
            src/test/resources/hudson/maven/JENKINS-1201-module-defined.zip
            src/test/resources/hudson/maven/JENKINS-1201-parent-defined.zip
            http://jenkins-ci.org/commit/maven-plugin/2f924d838f4ad49334531950cb3e7187ed147b69
            Log:
            Support for ciManagement maven notifications.

            In order to enable ciManagement maven notifications you have to check the
            option "E-mail Notification" into the section "Build Settings" from the
            job, and add a ciManagement section to the pom.xml with the following
            settings:

            ciManagement

            – system=hudson (you have to put "hudson" here )
            – ur=http://serverurl/
            – notifiers
            ----- notifier
            -------- type=mail (you have to put "mail" here)
            -------- sendOnError=true
            -------- sendOnFailure=true
            -------- sendOnSuccess>false
            -------- sendOnWarning>false
            -------- configuration
            ------------ recipients=some.email@domain.org (recipients have the same
            format than the same field in the Job configuration page)

            You can override this configuration in any module of the maven proyect.

            [FIXED JENKINS-1201]
            [FIXED JENKINS-6421]

            evernat evernat added a comment -

            Indeed, this is a duplicate of JENKINS-1201
            You can vote for it.

            brunojcm Bruno Medeiros added a comment - - edited

            Have you tried to change <system>hudson</system> to <system>jenkins</system>? Just a guess...

            EDIT: Found a related ticket, maybe it is not even implemented on Jenkins. https://issues.jenkins-ci.org/browse/JENKINS-1201

            chrisabit chrisabit added a comment -

            Wow - I report a major bug and no one even comments on this ???


              People

              • Assignee:
                Unassigned
                Reporter:
                chrisabit chrisabit
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: