Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6443

AggregatedTestResultPublisher$TestResultAction cannot be cast to hudson.tasks.test.TestResult

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: core
    • Labels:
      None
    • Environment:
      Hudson 1.356 on Java 1.6.0_20 x64, Windows Server 2008 x64
    • Similar Issues:
      Show 5 results

      Description

      I am having some issues with publishing of JUnit reports, in that certain data don't come out right. Aggregation of testresults is enabled. I see in Hudson's log that exceptions are reported, at least some of which have to do with testresult reporting. I've attached a paste of my log, so you should be able to grasp the context in which this is happening.

        Attachments

          Issue Links

            Activity

            Hide
            hoblin Evgeny Gurin added a comment -

            I just try to run jenkins on same server from WAR file without additional plugins with new build task and bug gone. I'll try to reproduce it on clean setup.

            Show
            hoblin Evgeny Gurin added a comment - I just try to run jenkins on same server from WAR file without additional plugins with new build task and bug gone. I'll try to reproduce it on clean setup.
            Hide
            hoblin Evgeny Gurin added a comment -

            Seems like running from WAR file fixes my first jenkins setup as well. Bug is gone and i can't reproduce it at all.

            Show
            hoblin Evgeny Gurin added a comment - Seems like running from WAR file fixes my first jenkins setup as well. Bug is gone and i can't reproduce it at all.
            Hide
            hoblin Evgeny Gurin added a comment -

            Ah, no. It appears again after i run build on the old setup. Magic... Ok, later I'll try to figure out how to reproduce it.

            Show
            hoblin Evgeny Gurin added a comment - Ah, no. It appears again after i run build on the old setup. Magic... Ok, later I'll try to figure out how to reproduce it.
            Hide
            hoblin Evgeny Gurin added a comment -

            Seems like it caused by one (or many) of old builds in .jenkins/jobs/JobName/builds/ dir. I'll try to find which one.

            Show
            hoblin Evgeny Gurin added a comment - Seems like it caused by one (or many) of old builds in .jenkins/jobs/JobName/builds/ dir. I'll try to find which one.
            Hide
            tyrael Ferenc Kovacs added a comment -

            I'm still seeing broken graphs with this error on my jenkins install (jenkins lts 1.447.1 running on debian squeeze).
            Some jobs (with the same config except they are using different git branches) are fine others borked.

            Show
            tyrael Ferenc Kovacs added a comment - I'm still seeing broken graphs with this error on my jenkins install (jenkins lts 1.447.1 running on debian squeeze). Some jobs (with the same config except they are using different git branches) are fine others borked.

              People

              • Assignee:
                Unassigned
                Reporter:
                aknuds1 Arve Knudsen
              • Votes:
                5 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated: