Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6466

Configure trend graph do not save # days setting

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: analysis-core-plugin
    • Labels:
      None
    • Environment:
      Windows 2003 Server
      Java 1.6.0_16
      Hudson 1.356
      Checkstyle Plug-in 3.6
      Static Analysis Utilities 1.8
    • Similar Issues:

      Description

      The Checkstyle trend configuration page do not save all values.

      Steps to reproduce:
      1)Click on the Configure link below the Checkstyle Trend graph on the Project page.
      2)Change the value for width from 500 to 400, and set the # days value to 21
      3)Click the save button
      4)Click again on the Configure link below the Checkstyle Trend graph on the Project page

      Expected:
      The width and days field should contain the newly set values.

      Actual result:
      The width field has the correct value. The days field are empty.

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          Actually the values are saved and used during the computation. Only the configuration view does not show the persisted values.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : drulli
          Path:
          trunk/hudson/plugins/analysis-core/src/main/java/hudson/plugins/analysis/graph/GraphConfigurationView.java
          trunk/hudson/plugins/analysis-core/src/main/java/hudson/plugins/analysis/util/CookieHandler.java
          http://jenkins-ci.org/commit/30818
          Log:
          [FIXED JENKINS-6466] Fixed display of #days and #build values in configuration view.

          drulli Ulli Hafner added a comment -

          This still seems to be broken for the default configuration (via .txt file and not via cookie).

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : drulli
          Path:
          trunk/hudson/plugins/analysis-core/src/main/java/hudson/plugins/analysis/graph/GraphConfiguration.java
          http://jenkins-ci.org/commit/31180
          Log:
          [FIXED JENKINS-6466] Added default value of 30 days and 50 builds when computing the trend graph.


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              amh Anders Hansen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: