Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6513

error in current version of plugins analysis-core, checkstyle, findbugs, pmd

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      checked on several platforms: Win7, Ubuntu, MacOSX

      Hudson ver. 1.357
      Static Analysis Utilities 1.8
      Static Analysis Collector Plug-in 1.5
      Checkstyle Plug-in 3.6
      FindBugs Plug-in 4.8
      PMD Plug-in 3.6

      Description

      I plan to use hudson with plugins analysis-core, analysis-collector, findbugs, pmd, checkstyle.
      after installing plugins analysis-core

      • the analysis-collector plugin fails with
        Failed to load hudson.plugins.analysis.collector.dashboard.WarningsOriginGraphPortlet$WarningsGraphDescriptor
        Failed to load hudson.plugins.analysis.collector.dashboard.WarningsOriginGraphPortlet$WarningsPerJobDescriptor
        Failed to load hudson.plugins.analysis.collector.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor
      • the checkstyle plugin fails with
        Failed to load hudson.plugins.checkstyle.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor
        Failed to load hudson.plugins.checkstyle.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor
        Failed to load hudson.plugins.checkstyle.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor
      • the findbugs plugin fails with
        Failed to load hudson.plugins.findbugs.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor
        Failed to load hudson.plugins.findbugs.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor
        Failed to load hudson.plugins.findbugs.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor
      • the pmd plugin fails with
        Failed to load hudson.plugins.pmd.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor
        Failed to load hudson.plugins.pmd.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor
        Failed to load hudson.plugins.pmd.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor

      full stack trace:

      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.analysis.collector.dashboard.WarningsOriginGraphPortlet$WarningsGraphDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.analysis.collector.dashboard.WarningsOriginGraphPortlet$WarningsGraphDescriptor.newInstance(WarningsOriginGraphPortlet.java:69)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.analysis.collector.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.analysis.collector.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor.newInstance(WarningsTablePortlet.java:412)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.analysis.collector.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.analysis.collector.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor.newInstance(WarningsNewVersusFixedGraphPortlet.java:69)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.analysis.collector.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.analysis.collector.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor.newInstance(WarningsPriorityGraphPortlet.java:69)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.checkstyle.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.checkstyle.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor.newInstance(WarningsPriorityGraphPortlet.java:69)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.checkstyle.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.checkstyle.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor.newInstance(WarningsTablePortlet.java:55)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.checkstyle.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.checkstyle.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor.newInstance(WarningsNewVersusFixedGraphPortlet.java:69)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.findbugs.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.findbugs.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor.newInstance(WarningsNewVersusFixedGraphPortlet.java:69)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.findbugs.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.findbugs.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor.newInstance(WarningsPriorityGraphPortlet.java:69)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.findbugs.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.findbugs.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor.newInstance(WarningsTablePortlet.java:55)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.pmd.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.pmd.dashboard.WarningsPriorityGraphPortlet$WarningsGraphDescriptor.newInstance(WarningsPriorityGraphPortlet.java:69)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.pmd.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:124)
      	at hudson.DescriptorExtensionList.load(DescriptorExtensionList.java:144)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      	at hudson.ExtensionList.iterator(ExtensionList.java:113)
      	at hudson.model.ComputerSet.<clinit>(ComputerSet.java:367)
      	at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      	at java.util.TimerThread.mainLoop(Unknown Source)
      	at java.util.TimerThread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:151)
      	... 13 more
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/view/dashboard/DashboardPortlet
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(Unknown Source)
      	at java.lang.ClassLoader.defineClass(Unknown Source)
      	at java.security.SecureClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.defineClass(Unknown Source)
      	at java.net.URLClassLoader.access$000(Unknown Source)
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:374)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at hudson.plugins.pmd.dashboard.WarningsTablePortlet$WarningsPerJobDescriptor.newInstance(WarningsTablePortlet.java:55)
      	... 18 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	... 34 more
      
      hudson.ExtensionFinder$Sezpoz find
      WARNUNG: Failed to load hudson.plugins.pmd.dashboard.WarningsNewVersusFixedGraphPortlet$WarningsGraphDescriptor
      java.lang.InstantiationException: java.lang.reflect.InvocationTargetException
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:159)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:123)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
      	at hudson.ExtensionList.load(ExtensionList.java:232)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:214)
      

        Activity

        bw_uezi bw_uezi created issue -
        mindless Alan Harder added a comment -

        Here was my reply in the thread on the users alias:

        This is a warning, and safe to ignore.
        But yes, it prints a LOT of messages in the log.
        (you could install dashboard view plugin to make the warnings go away)

        Ulli, for now you can change your "newInstance" method to return null if
        dashboard view plugin is not present, as done in this commit for
        promoted-builds-simple:
        https://hudson.dev.java.net/source/browse/hudson?view=rev&rev=30964

        And, when your plugin uses parent version 1.358 or higher (yes, not
        released yet.. I just made this change) you can remove your static
        newInstance method and put @Extension(optional=true) on the Descriptor
        class.

        scm_issue_link SCM/JIRA link daemon added a comment -

        Code changed in hudson
        User: : drulli
        Path:
        trunk/hudson/plugins/analysis-collector/src/main/java/hudson/plugins/analysis/collector/AnalysisResult.java
        trunk/hudson/plugins/analysis-collector/src/main/java/hudson/plugins/analysis/collector/dashboard/WarningsNewVersusFixedGraphPortlet.java
        trunk/hudson/plugins/analysis-collector/src/main/java/hudson/plugins/analysis/collector/dashboard/WarningsOriginGraphPortlet.java
        trunk/hudson/plugins/analysis-collector/src/main/java/hudson/plugins/analysis/collector/dashboard/WarningsPriorityGraphPortlet.java
        trunk/hudson/plugins/analysis-collector/src/main/java/hudson/plugins/analysis/collector/dashboard/WarningsTablePortlet.java
        trunk/hudson/plugins/checkstyle/src/main/java/hudson/plugins/checkstyle/dashboard/WarningsNewVersusFixedGraphPortlet.java
        trunk/hudson/plugins/checkstyle/src/main/java/hudson/plugins/checkstyle/dashboard/WarningsPriorityGraphPortlet.java
        trunk/hudson/plugins/checkstyle/src/main/java/hudson/plugins/checkstyle/dashboard/WarningsTablePortlet.java
        trunk/hudson/plugins/dry/src/main/java/hudson/plugins/dry/dashboard/WarningsNewVersusFixedGraphPortlet.java
        trunk/hudson/plugins/dry/src/main/java/hudson/plugins/dry/dashboard/WarningsPriorityGraphPortlet.java
        trunk/hudson/plugins/dry/src/main/java/hudson/plugins/dry/dashboard/WarningsTablePortlet.java
        trunk/hudson/plugins/findbugs/plugin/src/main/java/hudson/plugins/findbugs/dashboard/WarningsNewVersusFixedGraphPortlet.java
        trunk/hudson/plugins/findbugs/plugin/src/main/java/hudson/plugins/findbugs/dashboard/WarningsPriorityGraphPortlet.java
        trunk/hudson/plugins/findbugs/plugin/src/main/java/hudson/plugins/findbugs/dashboard/WarningsTablePortlet.java
        trunk/hudson/plugins/pmd/src/main/java/hudson/plugins/pmd/dashboard/WarningsNewVersusFixedGraphPortlet.java
        trunk/hudson/plugins/pmd/src/main/java/hudson/plugins/pmd/dashboard/WarningsPriorityGraphPortlet.java
        trunk/hudson/plugins/pmd/src/main/java/hudson/plugins/pmd/dashboard/WarningsTablePortlet.java
        trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/dashboard/WarningsNewVersusFixedGraphPortlet.java
        trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/dashboard/WarningsPriorityGraphPortlet.java
        trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/dashboard/WarningsTablePortlet.java
        trunk/hudson/plugins/warnings/clean.sh
        trunk/hudson/plugins/warnings/go.sh
        trunk/hudson/plugins/warnings/src/main/java/hudson/plugins/warnings/dashboard/WarningsNewVersusFixedGraphPortlet.java
        trunk/hudson/plugins/warnings/src/main/java/hudson/plugins/warnings/dashboard/WarningsPriorityGraphPortlet.java
        trunk/hudson/plugins/warnings/src/main/java/hudson/plugins/warnings/dashboard/WarningsTablePortlet.java
        http://jenkins-ci.org/commit/31212
        Log:
        [FIXED JENKINS-6513] Replaced broken newInstance method with @Extension(optional = true).

        scm_issue_link SCM/JIRA link daemon made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        abayer abayer made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            drulli Ulli Hafner
            Reporter:
            bw_uezi bw_uezi
          • Votes:
            3 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: