Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6595

FATAL: Failed to serialize hudson.model.Project#buildWrappers for class hudson.model.FreeStyleProject - possibly related to envfile plugin and xstream

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Hudson 1.355 with Winstone running on RHEL AS release 4 (October Update 7)
      envfile plugin
    • Similar Issues:

      Description

      Hi,

      After successfully building several times, a free style job would start failing with following stack trace in consoleText. Here is my configuration-

      Hudson - 1.355
      Perforce Plugin - 1.0.29
      Hudson Environment File Plugin - 1.0
      Hudson Active Directory plugin - 1.16
      Hudson SSH Slaves plugin - 0.10
      Hudson Performance plugin - 1.2
      Hudson Email Extension Plugin - 2.5
      Maven 2 Project Plugin - 1.355
      Warnings Plug-in - 3.5
      CVS Plugin - 1.0
      Subversion Plugin - 1.13
      Hudson Support Subscription Notification Plugin - 1.2
      Static Analysis Utilities - 1.8
      Audit Trail - 1.4
      Violations - 0.7.1
      Configuration Slicing plugin - 1.16
      Claim Plugin - 1.7
      Hudson Job Configuration History Plugin - 1.4

      Here is the stack trace that I see in consoleText

      — SNIP —

      Sync complete, took 12442 ms
      FATAL: Failed to serialize hudson.model.Project#buildWrappers for class hudson.model.FreeStyleProject
      java.lang.RuntimeException: Failed to serialize hudson.model.Project#buildWrappers for class hudson.model.FreeStyleProject
      	at hudson.util.RobustReflectionConverter$2.writeField(RobustReflectionConverter.java:164)
      	at hudson.util.RobustReflectionConverter$2.visit(RobustReflectionConverter.java:135)
      	at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.visitSerializableFields(PureJavaReflectionProvider.java:130)
      	at hudson.util.RobustReflectionConverter.doMarshal(RobustReflectionConverter.java:120)
      	at hudson.util.RobustReflectionConverter.marshal(RobustReflectionConverter.java:94)
      	at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:68)
      	at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:78)
      	at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:63)
      	at com.thoughtworks.xstream.core.TreeMarshaller.start(TreeMarshaller.java:98)
      	at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.marshal(AbstractTreeMarshallingStrategy.java:38)
      	at com.thoughtworks.xstream.XStream.marshal(XStream.java:840)
      	at com.thoughtworks.xstream.XStream.marshal(XStream.java:829)
      	at com.thoughtworks.xstream.XStream.toXML(XStream.java:804)
      	at hudson.XmlFile.write(XmlFile.java:165)
      	at hudson.model.AbstractItem.save(AbstractItem.java:220)
      	at hudson.plugins.perforce.PerforceSCM.checkout(PerforceSCM.java:579)
      	at hudson.model.AbstractProject.checkout(AbstractProject.java:1044)
      	at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:479)
      	at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:411)
      	at hudson.model.Run.run(Run.java:1244)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:122)
      Caused by: java.lang.RuntimeException: Failed to serialize hudson.plugins.envfile.EnvFileBuildWrapper#buildListner for class hudson.plugins.envfile.EnvFileBuildWrapper
      	at hudson.util.RobustReflectionConverter$2.writeField(RobustReflectionConverter.java:164)
      	at hudson.util.RobustReflectionConverter$2.visit(RobustReflectionConverter.java:135)
      	at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.visitSerializableFields(PureJavaReflectionProvider.java:130)
      	at hudson.util.RobustReflectionConverter.doMarshal(RobustReflectionConverter.java:120)
      	at hudson.util.RobustReflectionConverter.marshal(RobustReflectionConverter.java:94)
      	at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:68)
      	at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:78)
      	at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:63)
      	at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.writeItem(AbstractCollectionConverter.java:64)
      	at hudson.util.DescribableList$ConverterImpl.marshal(DescribableList.java:225)
      	at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:68)
      	at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:78)
      	at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:63)
      	at hudson.util.RobustReflectionConverter.marshallField(RobustReflectionConverter.java:172)
      	at hudson.util.RobustReflectionConverter$2.writeField(RobustReflectionConverter.java:160)
      	... 22 more
      Caused by: com.thoughtworks.xstream.converters.ConversionException: Could not call hudson.model.StreamBuildListener.writeObject() : Could not call hudson.remoting.RemoteOutputStream.writeObject() : null
      ---- Debugging information ----
      message             : Could not call hudson.remoting.RemoteOutputStream.writeObject()
      cause-exception     : java.lang.NullPointerException
      cause-message       : null
      -------------------------------
      message             : Could not call hudson.model.StreamBuildListener.writeObject()
      cause-exception     : com.thoughtworks.xstream.converters.ConversionException
      cause-message       : Could not call hudson.remoting.RemoteOutputStream.writeObject() : null
      -------------------------------
      	at com.thoughtworks.xstream.converters.reflection.SerializationMethodInvoker.callWriteObject(SerializationMethodInvoker.java:104)
      	at com.thoughtworks.xstream.converters.reflection.SerializableConverter.doMarshal(SerializableConverter.java:215)
      	at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.marshal(AbstractReflectionConverter.java:58)
      	at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:68)
      	at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:78)
      	at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:63)
      	at hudson.util.RobustReflectionConverter.marshallField(RobustReflectionConverter.java:172)
      	at hudson.util.RobustReflectionConverter$2.writeField(RobustReflectionConverter.java:160)
      	... 36 more
      Caused by: com.thoughtworks.xstream.converters.ConversionException: Could not call hudson.remoting.RemoteOutputStream.writeObject() : null
      ---- Debugging information ----
      message             : Could not call hudson.remoting.RemoteOutputStream.writeObject()
      cause-exception     : java.lang.NullPointerException
      cause-message       : null
      -------------------------------
      	at com.thoughtworks.xstream.converters.reflection.SerializationMethodInvoker.callWriteObject(SerializationMethodInvoker.java:104)
      	at com.thoughtworks.xstream.converters.reflection.SerializableConverter.doMarshal(SerializableConverter.java:215)
      	at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.marshal(AbstractReflectionConverter.java:58)
      	at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:68)
      	at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:78)
      	at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:63)
      	at com.thoughtworks.xstream.converters.reflection.SerializableConverter$1.writeToStream(SerializableConverter.java:104)
      	at com.thoughtworks.xstream.core.util.CustomObjectOutputStream.writeObjectOverride(CustomObjectOutputStream.java:84)
      	at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:298)
      	at hudson.util.StreamTaskListener.writeObject(StreamTaskListener.java:152)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:585)
      	at com.thoughtworks.xstream.converters.reflection.SerializationMethodInvoker.callWriteObject(SerializationMethodInvoker.java:100)
      	... 43 more
      Caused by: java.lang.NullPointerException
      	at hudson.remoting.RemoteOutputStream.writeObject(RemoteOutputStream.java:82)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:585)
      	at com.thoughtworks.xstream.converters.reflection.SerializationMethodInvoker.callWriteObject(SerializationMethodInvoker.java:100)
      	... 57 more
      

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : km
            Path:
            trunk/hudson/plugins/envfile/src/main/java/hudson/plugins/envfile/EnvFileBuildWrapper.java
            trunk/hudson/plugins/envfile/src/test/java/hudson/plugins/envfile/EnvFileBuildWrapperTest.java
            http://jenkins-ci.org/commit/31535
            Log:
            [FIXED JENKINS-6595]
            Moved the things related to a "build" closer to "environment" in which
            the build runs.


              People

              • Assignee:
                Unassigned
                Reporter:
                kaizers kaizers
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: