Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6599

Hudson bzr always reports no changes in the change log

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: bazaar-plugin
    • Labels:
      None
    • Environment:
      Hudson 1.354, Bzr-Hudson plugin 1.6, Bzr 2.1.1
    • Similar Issues:

      Description

      The bzr plugin doesn't seem to report the changes in a build back to hudson. The changes page for a project states "No changes in any of the builds". This is the case for all the projects using bzr.

        Attachments

          Issue Links

            Activity

            zigarn Alexandre Garnier added a comment -

            Still having the problem ?
            Never seen that.
            What are the console output for those builds ?

            pvandervelde pvandervelde added a comment -

            Yeah the problem hasn't been solved yet but then there hasn't been an update to the plugin. What do you mean with console output? For the actual builds or for the polling log?
            The actual build console output seems all normal (the repository is branched and the build proceeds fine). As far as I remember (I don't have access to the machine at the moment) no output is produced while bzr is running, but the repository is correctly branched.

            pvandervelde pvandervelde added a comment -

            The latest outputs are:

            Polling log:
            Started on 29/10/2010 12:10:34 PM
            Getting current remote revision...$ bzr revision-info -d D:\repository\apollo\code\unstable\prealpha
            petrik@silversurfer-pc-20101011100309-s43s978yavrpp0nm
            Baseline is bazaar revid:petrik@silversurfer-pc-20101011100309-s43s978yavrpp0nm.
            Done. Took 0.76 sec
            No changes

            Last build:
            Build output (just the bzr related stuff):
            Started by an SCM change
            $ bzr branch D:\repository\apollo\code\unstable\prealpha
            E:\integration\hudson\jobs\Apollo-Unstable\workspace
            Branched 142 revision(s).
            Getting local revision...

            The changes link on the project page gives an empty page with no changes. The build is only triggered if there are changes in the repository so there must have been something.

            zigarn Alexandre Garnier added a comment -

            Do you configure the job with the "clean build" option for Bazaar (in "Advanced") ?
            If so, it's a duplicate of JENKINS-6761.
            Short term solution is to deactivate this option.

            pvandervelde pvandervelde added a comment -

            Yes I have configured it with the 'clean build' option. It looks like this one is a duplicate of JENKINS-6761. Thanks for pointing me in the right direction.


              People

              • Assignee:
                zigarn Alexandre Garnier
                Reporter:
                pvandervelde pvandervelde
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: