Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6603

NPE in GrailsBuilder.getTargetsToRun at start of build

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: grails-plugin
    • Labels:
      None
    • Environment:
      Hudson 1.358, Grails plugin 1.3, Grails 1.2.2, OpenJDK 6, Debian Linux
    • Similar Issues:

      Description

      After upgrading the Grails plugin, my build fails immediately with a NPE:

      FATAL: null
      java.lang.NullPointerException
      	at com.g2one.hudson.grails.GrailsBuilder.getTargetsToRun(GrailsBuilder.java:222)
      	at com.g2one.hudson.grails.GrailsBuilder.perform(GrailsBuilder.java:120)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
      	at hudson.model.Build$RunnerImpl.build(Build.java:174)
      	at hudson.model.Build$RunnerImpl.doRun(Build.java:138)
      	at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:416)
      	at hudson.model.Run.run(Run.java:1241)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:122)
      

      It is configured with the following in the "Targets" input field:

      clean "test-app -coverage -nopost -xml" codenarc war
      

        Attachments

          Activity

          mbetter Marcus Better added a comment -

          I think this affects upgrades from older versions of the plugin. I got additionally the following NPE when entering the job config page:

          ...
          Caused by: java.lang.NullPointerException
                  at com.g2one.hudson.grails.GrailsBuilder.getForceUpgrade(GrailsBuilder.java:55)
                  ... 156 more
          

          After checking the "force upgrade" checkbox, the build works.

          jeffg2one jeffg2one added a comment -

          Yes, I think the problem has to do with upgrading form an earlier version of the plugin. If you edit the job and resave it, the problem should go away. I will try to track this down and fix it for the next release.

          Thanks for your help.

          evernat evernat added a comment -

          hmmm, this was one year ago.
          I think that everyone who was using an old version has upgraded now (use "force upgrade" and save the job).

          So closing the issue as Won't fix.


            People

            • Assignee:
              jeffg2one jeffg2one
              Reporter:
              mbetter Marcus Better
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: