Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6964

Selenium plugin can't start RCs on slaves.

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: selenium-plugin
    • Labels:
      None
    • Environment:
      Windows XP
    • Similar Issues:

      Description

      Hudson can't start remote controls on slaves, but it does start them on the master node. The error message is "Unable to determine the host name. Skipping Selenium execution."

      Setting the host.name system property for the slave did not solve the problem.

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Note to myself: the root cause is that the error message isn't really actionable. It doesn't point the users to the right direction. We need the error message to come with a lot more details to help people understand what needs to be tweaked.

          Also, we should consider tunneling the RC/Grid communication over the master/slave channel to avoid this headache altogether (at least as a fallback)

          cookiecaper Jeff Cook added a comment -

          FYI I am experiencing this bug now. From Google it appears to be a somewhat common problem. I have set my hostname in Jenkins and still get this.

          dschulten Dietrich Schulten added a comment -

          In my setup, setting -Dhost.name did help if the slave is started manually from Hudson.
          But strangely, when starting the entire Hudson, I always have to kill the slave.jar process on the slave console and then I must restart the slave from Hudson. Otherwise, the selenium rc refuses to start with the above message.

          adamsmasher Adam Demuri added a comment - - edited

          As Jeff explains here (https://groups.google.com/forum/#!topic/jenkinsci-users/JwdvUSIe1MI), (one cause of) the issue seems to be Java's implementation of ping.

          I was seeing this problem with Jenkins running on Ubuntu and a slave on Windows. What solved the problem was installing the 'Simple TCP/IP Services' on Windows and 'xinetd' (and turning on echo) on Linux. This contains the 'ping' utility which runs on port 7. Apparently Java's implementation of ping uses this port/service on Linux. I'm not sure if echo functionality is needed on both machines or just one.


            People

            • Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              dpenny52 dpenny52
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: