Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6976

In incremental build mode - if a breaking commit is done to a module while another module is broken, the build eventually succeeds

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Hudson version 1.353
    • Similar Issues:

      Description

      Two unrelated modules A and B. According to the parent pom, B is built after A (but does not depend on it).

      1. John makes a commit to module A that breaks it.
      2. Hudson forks a build that compiles module A and fails.
      3. Paul makes a commit to module B that breaks it also.
      4. Hudson forks a build that intends to compile module B, but first compiles module A (it is still failed) and fails.
      5. John fixes module A.
      6. Hudson forks a build that compiles A only (B is not among its dependencies).

      ==> Build is marked successful while there is a "hidden time-bomb" in module B.

        Attachments

          Issue Links

            Activity

            kutzi kutzi added a comment -

            I think the behaviour was fixed, so that unstable/failing modules are alway rebuild.
            Can you retest with a current version of Hudson?

            victor_bronstein victor_bronstein added a comment -

            Have just verified with version 1.386. Still the same problem. The problem is that Hudson doesn't know that the module B is failing because it has never built it after the breaking change described at the item #3.

            kutzi kutzi added a comment -

            I think this is the same problem as JENKINS-5764


              People

              • Assignee:
                Unassigned
                Reporter:
                victor_bronstein victor_bronstein
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: