Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7013

Build fails to archive the artifacts

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Windows server 2008 64bit
      Windows XP Professional SP3
    • Similar Issues:

      Description

      Since last 2-3 versions (now 1.367) artifacts archiving fails with the following error:
      BUILD SUCCESSFUL
      Total time: 4 seconds
      Archiving artifacts
      ERROR: Failed to archive artifacts: publish/*/
      hudson.util.IOException2: Failed to copy c:\opencm\hudson\jobs\Jade_M1-daily\workspace/publish/*/ to c:\opencm\hudson\jobs\Jade_M1-daily\builds\2010-07-19_13-27-32\archive
      at hudson.FilePath$31.invoke(FilePath.java:1451)
      at hudson.FilePath$31.invoke(FilePath.java:1418)
      at hudson.FilePath.act(FilePath.java:753)
      at hudson.FilePath.act(FilePath.java:735)
      at hudson.FilePath.copyRecursiveTo(FilePath.java:1418)
      at hudson.tasks.ArtifactArchiver.perform(ArtifactArchiver.java:117)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:580)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:558)
      at hudson.model.Build$RunnerImpl.post2(Build.java:158)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
      at hudson.model.Run.run(Run.java:1280)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:129)
      Caused by: Failed to copy c:\opencm\hudson\jobs\Jade_M1-daily\workspace\publish\dailydictionary_50.47_19072010.mdb to c:\opencm\hudson\jobs\Jade_M1-daily\builds\2010-07-19_13-27-32\archive\publish\dailydictionary_50.47_19072010.mdb due to Map failed
      at org.apache.tools.ant.taskdefs.Copy.doFileOperations(Copy.java:853)
      at hudson.FilePath$31$1CopyImpl.doFileOperations(FilePath.java:1434)
      at org.apache.tools.ant.taskdefs.Copy.execute(Copy.java:523)
      at hudson.FilePath$31.invoke(FilePath.java:1448)
      ... 15 more
      Caused by: java.io.IOException: Map failed
      at sun.nio.ch.FileChannelImpl.map(FileChannelImpl.java:761)
      at sun.nio.ch.FileChannelImpl.transferToTrustedChannel(FileChannelImpl.java:450)
      at sun.nio.ch.FileChannelImpl.transferTo(FileChannelImpl.java:523)
      at org.apache.tools.ant.util.ResourceUtils.copyResource(ResourceUtils.java:475)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:519)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:481)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:310)
      at org.apache.tools.ant.taskdefs.Copy.doFileOperations(Copy.java:841)
      ... 18 more
      Caused by: java.lang.OutOfMemoryError: Map failed
      at sun.nio.ch.FileChannelImpl.map0(Native Method)
      at sun.nio.ch.FileChannelImpl.map(FileChannelImpl.java:758)
      ... 25 more
      Finished: SUCCESS

      Page generated: Jul 19, 2010 2:23:10 PMHudson ver. 1.367

      while some of the files are copied.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            I don't think last two comments from David is the same problem. Let's keep this ticket for the memory mapped file problem.

            peter_schuetze peter_schuetze added a comment - - edited

            Encountered this problem today.

            Windows 2003 Server SP2
            Java 1.6
            Jenkins 1.461
            File mentioned below is 45 MB

            21:25:55 Caused by: Failed to copy D:\Hudson\jobs\OCNS_Release_build\workspace\ocns-fitnesse\ocns-fitnesse-fixtures\ocns-fitnesse-fixtures-ear\target\ocns-fitnesse-fixtures-ear-0.1.ear to D:\Hudson\jobs\OCNS_Release_build\builds\2012-06-14_20-20-27\archive\ocns-fitnesse\ocns-fitnesse-fixtures\ocns-fitnesse-fixtures-ear\target\ocns-fitnesse-fixtures-ear-0.1.ear due to Map failed
            21:25:55 at org.apache.tools.ant.taskdefs.Copy.doFileOperations(Copy.java:914)
            21:25:55 at hudson.FilePath$34$1CopyImpl.doFileOperations(FilePath.java:1672)
            21:25:55 at org.apache.tools.ant.taskdefs.Copy.execute(Copy.java:567)
            21:25:55 at hudson.FilePath$34.invoke(FilePath.java:1686)
            21:25:55 ... 14 more
            21:25:55 Caused by: java.io.IOException: Map failed
            21:25:55 at sun.nio.ch.FileChannelImpl.map(Unknown Source)
            21:25:55 at sun.nio.ch.FileChannelImpl.transferFromFileChannel(Unknown Source)
            21:25:55 at sun.nio.ch.FileChannelImpl.transferFrom(Unknown Source)
            21:25:55 at org.apache.tools.ant.util.ResourceUtils.copyResource(ResourceUtils.java:532)
            21:25:55 at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:559)
            21:25:55 at org.apache.tools.ant.taskdefs.Copy.doFileOperations(Copy.java:899)
            21:25:55 ... 17 more
            21:25:55 Caused by: java.lang.OutOfMemoryError: Map failed
            21:25:55 at sun.nio.ch.FileChannelImpl.map0(Native Method)
            21:25:55 ... 23 more
            21:26:14 Notifying upstream projects of job completion
            21:26:14 Finished: FAILURE

            richardtaylor Richard Taylor added a comment -

            We have just started getting this error when archiving from slave to master. The failure started occuring when our archive file size became larget than 8GB.

            [Both slave and master]
            Windows Server 2008 R2
            Java 1.6.0_30
            Jenkins 1.470

            This trace is slightly different form the ones above in that it has died in readFromTar().

            09:32:16 hudson.util.IOException2: hudson.util.IOException2: Failed to extract c:\jenkins\workspace\evo11main/evo11-* 09:32:16 at hudson.FilePath.readFromTar(FilePath.java:1843) 09:32:16 at hudson.FilePath.copyRecursiveTo(FilePath.java:1755) 09:32:16 at hudson.tasks.ArtifactArchiver.perform(ArtifactArchiver.java:116) 09:32:16 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) 09:32:16 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:717) 09:32:16 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:692) 09:32:16 at hudson.model.Build$BuildExecution.post2(Build.java:183) 09:32:16 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:639) 09:32:16 at hudson.model.Run.execute(Run.java:1485) 09:32:16 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) 09:32:16 at hudson.model.ResourceController.execute(ResourceController.java:88) 09:32:16 at hudson.model.Executor.run(Executor.java:239) 09:32:16 Caused by: java.io.FileNotFoundException: f:\jenkins\jobs\evo11-PKG\builds\2012-09-10_09-16-27\archive??m?O?U-D?#?D{2?m?`?M&?-?+?bk?1?????0!?"? N?L?T??F9?#9?a?v (The filename, directory name, or volume label syntax is incorrect) 09:32:16 at java.io.FileOutputStream.open(Native Method) 09:32:16 at java.io.FileOutputStream.<init>(Unknown Source) 09:32:16 at java.io.FileOutputStream.<init>(Unknown Source) 09:32:16 at hudson.util.IOUtils.copy(IOUtils.java:34) 09:32:16 at hudson.FilePath.readFromTar(FilePath.java:1833) 09:32:16 ... 11 more 09:32:16
            09:32:16 at hudson.FilePath.copyRecursiveTo(FilePath.java:1762)
            09:32:16 at hudson.tasks.ArtifactArchiver.perform(ArtifactArchiver.java:116)
            09:32:16 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
            09:32:16 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:717)
            09:32:16 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:692)
            09:32:16 at hudson.model.Build$BuildExecution.post2(Build.java:183)
            09:32:16 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:639)
            09:32:16 at hudson.model.Run.execute(Run.java:1485)
            09:32:16 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
            09:32:16 at hudson.model.ResourceController.execute(ResourceController.java:88)
            09:32:16 at hudson.model.Executor.run(Executor.java:239)
            09:32:16 Caused by: java.util.concurrent.ExecutionException: java.io.IOException: Pipe is already closed
            09:32:16 at hudson.remoting.Channel$3.adapt(Channel.java:679)
            09:32:16 at hudson.remoting.Channel$3.adapt(Channel.java:674)
            09:32:16 at hudson.remoting.FutureAdapter.get(FutureAdapter.java:59)
            09:32:16 at hudson.FilePath.copyRecursiveTo(FilePath.java:1758)
            09:32:16 ... 10 more
            09:32:16 Caused by: java.io.IOException: Pipe is already closed
            09:32:16 at hudson.remoting.PipeWindow.checkDeath(PipeWindow.java:83)
            09:32:16 at hudson.remoting.PipeWindow$Real.get(PipeWindow.java:171)
            09:32:16 at hudson.remoting.ProxyOutputStream._write(ProxyOutputStream.java:118)
            09:32:16 at hudson.remoting.ProxyOutputStream.write(ProxyOutputStream.java:103)
            09:32:16 at java.io.BufferedOutputStream.flushBuffer(Unknown Source)
            09:32:16 at java.io.BufferedOutputStream.write(Unknown Source)
            09:32:16 at java.util.zip.DeflaterOutputStream.deflate(Unknown Source)
            09:32:16 at java.util.zip.DeflaterOutputStream.write(Unknown Source)
            09:32:16 at java.util.zip.GZIPOutputStream.write(Unknown Source)
            09:32:16 at java.io.BufferedOutputStream.write(Unknown Source)
            09:32:16 at org.apache.tools.tar.TarBuffer.writeBlock(TarBuffer.java:410)
            09:32:16 at org.apache.tools.tar.TarBuffer.writeRecord(TarBuffer.java:351)
            09:32:16 at hudson.org.apache.tools.tar.TarOutputStream.writeEOFRecord(TarOutputStream.java:356)
            09:32:16 at hudson.org.apache.tools.tar.TarOutputStream.finish(TarOutputStream.java:137)
            09:32:16 at hudson.org.apache.tools.tar.TarOutputStream.close(TarOutputStream.java:149)
            09:32:16 at hudson.util.io.TarArchiver.close(TarArchiver.java:119)
            09:32:16 at hudson.FilePath.writeToTar(FilePath.java:1809)
            09:32:16 at hudson.FilePath.access$1000(FilePath.java:166)
            09:32:16 at hudson.FilePath$36.invoke(FilePath.java:1748)
            09:32:16 at hudson.FilePath$36.invoke(FilePath.java:1745)
            09:32:16 at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2180)
            09:32:16 at hudson.remoting.UserRequest.perform(UserRequest.java:118)
            09:32:16 at hudson.remoting.UserRequest.perform(UserRequest.java:48)
            09:32:16 at hudson.remoting.Request$2.run(Request.java:287)
            09:32:16 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
            09:32:16 at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
            09:32:16 at java.util.concurrent.FutureTask.run(Unknown Source)
            09:32:16 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
            09:32:16 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            09:32:16 at hudson.remoting.Engine$1$1.run(Engine.java:60)
            09:32:16 at java.lang.Thread.run(Unknown Source)
            09:32:16 Caused by: java.io.IOException: Pipe is already closed
            09:32:16 at hudson.remoting.FastPipedOutputStream.write(FastPipedOutputStream.java:147)
            09:32:16 at hudson.remoting.FastPipedOutputStream.write(FastPipedOutputStream.java:131)
            09:32:16 at hudson.remoting.ProxyOutputStream$Chunk$1.run(ProxyOutputStream.java:211)
            09:32:16 at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
            09:32:16 at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
            09:32:16 at java.util.concurrent.FutureTask.run(Unknown Source)
            09:32:16 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
            09:32:16 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            09:32:16 ... 1 more
            09:32:16 Caused by: hudson.remoting.FastPipedInputStream$ClosedBy: The pipe was closed at...
            09:32:16 at hudson.remoting.FastPipedInputStream.close(FastPipedInputStream.java:112)
            09:32:16 at java.io.FilterInputStream.close(Unknown Source)
            09:32:16 at java.util.zip.InflaterInputStream.close(Unknown Source)
            09:32:16 at java.util.zip.GZIPInputStream.close(Unknown Source)
            09:32:16 at org.apache.tools.tar.TarBuffer.close(TarBuffer.java:456)
            09:32:16 at hudson.org.apache.tools.tar.TarInputStream.close(TarInputStream.java:110)
            09:32:16 at hudson.FilePath.readFromTar(FilePath.java:1850)
            09:32:16 at hudson.FilePath.copyRecursiveTo(FilePath.java:1755)
            09:32:16 at hudson.tasks.ArtifactArchiver.perform(ArtifactArchiver.java:116)
            09:32:16 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
            09:32:16 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:717)
            09:32:16 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:692)
            09:32:16 at hudson.model.Build$BuildExecution.post2(Build.java:183)
            09:32:16 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:639)
            09:32:16 at hudson.model.Run.execute(Run.java:1485)
            09:32:16 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
            09:32:16 at hudson.model.ResourceController.execute(ResourceController.java:88)
            09:32:16 at hudson.model.Executor.run(Executor.java:239)

            Thanks

            danielbeck Daniel Beck added a comment -

            Does this issue still occur on recent Jenkins versions? I mean the OutOfMemoryError, not the issue with files larger than 8GB, that's tracked as JENKINS-10629.

            danielbeck Daniel Beck added a comment -

            Given the age of this issue and lack of response to the recent comment asking for updated information, resolving as Fixed again.

            If something similar occurs on recent versions of Jenkins, please file a new bug report so it can be investigated independent of this issue's history.


              People

              • Assignee:
                abayer Andrew Bayer
                Reporter:
                liyatikal liyatikal
              • Votes:
                9 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: