Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-719

Deployment problem on Tomcat 5.5 (Ubuntu 7.04)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      Trying to install Hudson on a freshly installed Ubuntu 7.04 machine with Tomcat
      5.5 as servlet engine, but the startup fails. I have searched for missing
      dependencies but found none.

      Stacktrace:

      2007-aug-09 13:58:56 org.apache.catalina.core.StandardContext listenerStart
      ALLVARLIG: Exception sending context initialized event to listener instance of
      class hudson.WebAppMain
      java.lang.ExceptionInInitializerError
      at com.thoughtworks.xstream.XStream.<init>(XStream.java:275)
      at com.thoughtworks.xstream.XStream.<init>(XStream.java:299)
      at hudson.util.XStream2.<init>(XStream2.java:19)
      at hudson.model.Hudson.<clinit>(Hudson.java:1788)
      at hudson.WebAppMain.installLogger(WebAppMain.java:128)
      at hudson.WebAppMain.contextInitialized(WebAppMain.java:42)
      at
      org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3763)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4211)
      at
      org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
      at org.apache.catalina.core.ContainerBase.access$0(ContainerBase.java:743)
      at
      org.apache.catalina.core.ContainerBase$PrivilegedAddChild.run(ContainerBase.java:143)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:737)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
      at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:809)
      at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:698)
      at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:472)
      at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1122)
      at
      org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:310)
      at
      org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1021)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:718)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1013)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:442)
      at org.apache.catalina.core.StandardService.start(StandardService.java:450)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:709)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:551)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:294)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at
      org.apache.commons.daemon.support.DaemonLoader.start(DaemonLoader.java:177)
      Caused by: java.security.AccessControlException: access denied
      (java.lang.RuntimePermission accessDeclaredMembers)
      at
      java.security.AccessControlContext.checkPermission(AccessControlContext.java:323)
      at java.security.AccessController.checkPermission(AccessController.java:546)
      at java.lang.SecurityManager.checkPermission(SecurityManager.java:532)
      at java.lang.SecurityManager.checkMemberAccess(SecurityManager.java:1662)
      at java.lang.Class.checkMemberAccess(Class.java:2157)
      at java.lang.Class.getDeclaredFields(Class.java:1742)
      at com.thoughtworks.xstream.core.JVM.<clinit>(JVM.java:24)
      ... 37 more
      2007-aug-09 13:58:56 org.apache.catalina.core.StandardContext listenerStop
      ALLVARLIG: Exception sending context destroyed event to listener instance of
      class hudson.WebAppMain
      java.lang.NoClassDefFoundError: Could not initialize class hudson.model.Hudson
      at hudson.WebAppMain.contextDestroyed(WebAppMain.java:176)
      at
      org.apache.catalina.core.StandardContext.listenerStop(StandardContext.java:3804)
      at org.apache.catalina.core.StandardContext.stop(StandardContext.java:4352)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4241)
      at
      org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
      at org.apache.catalina.core.ContainerBase.access$0(ContainerBase.java:743)
      at
      org.apache.catalina.core.ContainerBase$PrivilegedAddChild.run(ContainerBase.java:143)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:737)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
      at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:809)
      at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:698)
      at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:472)
      at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1122)
      at
      org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:310)
      at
      org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1021)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:718)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1013)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:442)
      at org.apache.catalina.core.StandardService.start(StandardService.java:450)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:709)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:551)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:294)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at
      org.apache.commons.daemon.support.DaemonLoader.start(DaemonLoader.java:177)

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          This is because Tomcat in Ubuntu comes with the security manager.
          I updated http://hudson.gotdns.com/wiki/display/JENKINS/Tomcat to capture this.
          Also see http://jspwiki.org/wiki/BugFailsToLoadOnUbuntuDapperInstall for a
          relevant discussion.

          Since security manager is a common problem, I updated the code to detect this
          situation and report a nice friendly error message. The change will be in 1.128.


            People

            • Assignee:
              Unassigned
              Reporter:
              c96mud c96mud
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: