Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7248

Matrix-Job configuration did not recognise if node was deleted

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Incomplete
    • Component/s: core
    • Labels:
      None
    • Environment:
      hudson build #1.367
    • Similar Issues:

      Description

      • have a node named "toBeDeleted"
      • set up a matrix job with this node and others
      • delete the "toBeDeleted" node
      • execute the matrix job -> it will still try to execute on the "toBeDeleted" node

      to clean up the problem you need to set up a new node with the same name and first clean the matrix job and than delete the node again, because if a node is deleted the node cannot be found in the label tree in the matrix configuration, but the configuration still holds the old node.

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Needs to be reproduced on recent Jenkins (preferably one with detached Matrix Project plugin).

          Also, not sure why a new node needs to be set up rather than just changing project configuration.


            People

            • Assignee:
              Unassigned
              Reporter:
              tofuatjava Thomas Fürer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: