Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7403

Build history timeline doesn't display in IE8

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Windows 7 64-bit, Internet Explorer 8
    • Similar Issues:

      Description

      Going to https://server/hudson/builds in IE8 results in a script error. The timeline then doesn't display (it's just an empty box). The timeline displays properly in Chrome, so it does work correctly on our server.

      Webpage error details
      
      User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; .NET4.0C)
      Timestamp: Wed, 8 Sep 2010 13:38:01 UTC
      
      Message: Object doesn't support this property or method
      Line: 18
      Char: 5
      Code: 0
      URI: https://hudson.server.local/hudson/builds

      Line 18 is the window.addEventListener() line:

      <script>
          var tz = -8.0;
          
          window.addEventListener('load', function() {
              var tl_el = document.getElementById("tl");
      ...

        Attachments

          Issue Links

            Activity

            fredg Fred G added a comment -

            This issue is not a complete duplicate of JENKINS-6439. It's one of the problems described there, and hasn't been fixed as of Jenkins version 1.440. Therefore reopening.

            fredg Fred G added a comment -

            Link describes a possible solution for the problem: http://msdn.microsoft.com/en-us/library/cc197055%28v=vs.85%29.aspx

            fredg Fred G added a comment -
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Fred G
            Path:
            changelog.html
            core/src/main/resources/hudson/model/BuildTimelineWidget/control.jelly
            http://jenkins-ci.org/commit/jenkins/7870d1987dceeab111f7a03455035d251724d02a
            Log:
            [FIXED JENKINS-7403] Build history timeline doesn't display in IE8

            Use window.attachEvent if window.addEventListener is not supported.

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #1331
            [FIXED JENKINS-7403] Build history timeline doesn't display in IE8

            Kohsuke Kawaguchi : 7870d1987dceeab111f7a03455035d251724d02a
            Files :

            • core/src/main/resources/hudson/model/BuildTimelineWidget/control.jelly
            • changelog.html

              People

              • Assignee:
                rherrick rherrick
                Reporter:
                rherrick rherrick
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: