Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7642

Perforce Label Not Applied to Client View

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: perforce-plugin
    • Labels:
      None
    • Environment:
      Windows2003, Windows 2008 - Tomcat 6.0.20, Java 1.6.0_06
    • Similar Issues:

      Description

      I had the problem with JENKINS-7558, where it looks like the label wasn't working when the plugin wasn't configured allow Hudson to manage the client view.

      I downloaded and installed latest Perforce Plugin with 1.375 and I no longer get the NPE and it appears a label is being created in Perforce. The problem now, unfortunately, is that the files in the workspace aren't being labeled. If I view the history of the file, no labels appear on any of the file revisions.

      I've enclosed a screenshot of the label description. There's seems to be two things incorrectly configured.

      First, the label view only includes the first row of my client workspace view, it should contain a great number of items (500+) and second, it appears there's no owner specified for the label.

      Should this be the name of the user configured in the Perforce plugin to perform the polling and sync'ing? I don't know if if this is a problem, but creating a label manually in the Perforce client always seems to add the owner. I did try adding an owner to the label hudson created, and that didn't seem to matter.

      Perhaps there's something off when in adding the second item to the view that's preventing the label from being applied fully.

      I have two builds attempting to label and they both exhibit the problem - and have only one item in the label view.

        Attachments

          Activity

          rpetti Rob Petti added a comment -

          It shouldn't need an owner, but the fact that it doesn't have one is odd. Perforce should automatically be assigning it to the user who created it. It looks like it simply isn't adding all the views to the label, so hopefully it'll be an easy fix.

          rpetti Rob Petti added a comment -

          Does the View field in the project configuration have all the same view mappings from your client spec?

          rpetti Rob Petti added a comment -

          Nevermind, I think I found the problem. Also keep in mind that labels still might not show up in the perforce history because these are automatic labels. This is a limitation of perforce, unfortunately.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : rpetti
          Path:
          trunk/hudson/plugins/perforce/src/main/java/com/tek42/perforce/model/AbstractViewsSupport.java
          trunk/hudson/plugins/perforce/src/main/java/hudson/plugins/perforce/PerforceSCM.java
          http://jenkins-ci.org/commit/35453
          Log:
          [FIXED JENKINS-7642] fixed parsing issue when dealing with client specs from perforce. This may also fix JENKINS-6834

          rpetti Rob Petti added a comment -

          Resolving as fixed since scm_issue_link is asleep or something...

          jed624 jed624 added a comment -

          Thank you very much for fixing this issue. Do you believe the next plugin will be available soon? Just wondering, because it would help address a few problems with some new features I'm rolling out in my Dev team. Thanks.

          rpetti Rob Petti added a comment -

          Yeah, I ran into a major regression last night on our production server (I try to eat my own dog food, so to speak) so I've been busy fixing that. I should have a release out later today or tomorrow.


            People

            • Assignee:
              rpetti Rob Petti
              Reporter:
              jed624 jed624
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: