Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7644

Issue priority shifted with 4.13

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      After upgrading to the findbugs plugin 4.13, all "normal priority (p2)" issues are now categorized as "low priority". I have no P1 issues, but I assume they would show up as P2 in the hudson report.
      The findbugs report XML is built with the official findbugs 1.3.9 version and lists the issues as P2 instead of P3.

      My guess what happened: You base your plugin on snapshot builds of findbugs. Perhaps the findbugs team decided to change the priority indicator from 1..3 to 0..2, which would lead to the symptoms I observe.
      Here is a line from the report XML that shows up as P3 issue in hudson and P2 issue in the findbugs HTML report:
      <BugInstance type="RV_RETURN_VALUE_IGNORED_BAD_PRACTICE" priority="2" abbrev="RV" category="BAD_PRACTICE" instanceHash="8121cc4d4cb2107f0be2286da704c324" instanceOccurrenceNum="0" instanceOccurrenceMax="0">

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          As far as I understood the changes in the findbugs API the warning priority is now derived from the bug rank. Do you think it is better to revert to the old behavior?

          What do you think Keith?

          dlindner dlindner added a comment -

          If this is a change in the findbugs way of categorizing warnings, then you are just ahead of your time a few weeks. I would not artificially revert back, but documentate this behaviour clearly as most people will run findbugs 1.3.9. It's not a bug then, but a "future feature".

          If the discrepancy between the findbugs HTML report and the hudson plugin report will stay even with the official findbugs 1.3.10 release, it's a bug and should be fixed.

          Thank you for looking into this.

          keithkml keithkml added a comment -

          Sorry! Forgot to document this change. See, this is why we wanted to change the terminology to say "scary" etc

          Yes, the plugin now uses Bug Rank, which is a more nuanced and "accurate" method of determining the priority of a bug.

          Anyway, I've added a line to the release notes page at http://wiki.jenkins-ci.org/display/JENKINS/FindBugs+Plugin

          drulli Ulli Hafner added a comment -

          Reopened since I added a property to toggle the behavior in JENKINS-8558.

          drulli Ulli Hafner added a comment -

          Will be part of 4.24.


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              dlindner dlindner
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: