Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7748

ERROR: Publisher hudson.plugins.tasks.TasksPublisher aborted due to exception

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: tasks-plugin
    • Labels:
      None
    • Environment:
      Hudson version is 1.379, windows 7 OS,
    • Similar Issues:

      Description

      Hello All,

      While building my nightly build i am getting the following err :

      BUILD SUCCESSFUL
      Total time: 11 minutes 24 seconds
      [TASKS] Scanning workspace files for tasks...
      ERROR: Publisher hudson.plugins.tasks.TasksPublisher aborted due to exception
      java.lang.NullPointerException: Name is null
      at java.lang.Enum.valueOf(Enum.java:195)
      at hudson.plugins.analysis.util.model.Priority.valueOf(Priority.java:18)
      at hudson.plugins.analysis.core.HealthAwarePublisher.getMinimumPriority(HealthAwarePublisher.java:522)
      at hudson.plugins.analysis.core.AbstractHealthDescriptor.<init>(AbstractHealthDescriptor.java:36)
      at hudson.plugins.tasks.TasksHealthDescriptor.<init>(TasksHealthDescriptor.java:26)
      at hudson.plugins.tasks.TasksResultAction.<init>(TasksResultAction.java:31)
      at hudson.plugins.tasks.TasksPublisher.perform(TasksPublisher.java:175)
      at hudson.plugins.analysis.core.HealthAwarePublisher.perform(HealthAwarePublisher.java:280)
      at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:27)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:580)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:558)
      at hudson.model.Build$RunnerImpl.post2(Build.java:157)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
      at hudson.model.Run.run(Run.java:1303)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:137)
      Archiving artifacts
      Recording fingerprints

      I have tried a lot but could not find the reason of this failure, i upgraded hudson to new version 2 days ago.
      Is this err is coming because of this?

      I have also attached the Task Scanner Plugin conf. of my nightly build. I am also using Sonar plugin.

      Please give me any idea why it is coming. is it a bug?

      Thanks,
      Khush.

        Attachments

          Activity

          eguess74 eguess74 added a comment -

          I suddenly have the same issue with checkstyle publisher for only one of the jobs. Hudson 1.379, checkstyle 3.10

          joecolade joecolade added a comment -

          Same with Hudson ver. 1.374


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              chahalkhushwinder chahalkhushwinder
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: