Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7784

Maven integration appears broken in 1.380

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      hudson 1.380,maven 2.2.1
    • Similar Issues:

      Description

      After upgrading to hudson 1.380 from 1.376 I am having severe problems building. Mostly during archive

      One exception I get is
      HUDSON] Archiving site from /xdata/hudson/.hudson/jobs/Build_Foundation/workspace/target/site to /xdata/hudson/.hudson/jobs/Build_Foundation/site
      FATAL: Unable to copy site from /xdata/hudson/.hudson/jobs/Build_Foundation/workspace/target/site to /xdata/hudson/.hudson/jobs/Build_Foundation/site
      hudson.util.IOException2: hudson.util.IOException2: Failed to extract /xdata/hudson/.hudson/jobs/Build_Foundation/workspace/target/site/*/
      at hudson.FilePath.copyRecursiveTo(FilePath.java:1474)
      at hudson.FilePath.copyRecursiveTo(FilePath.java:1399)
      at hudson.maven.reporters.MavenSiteArchiver.postExecute(MavenSiteArchiver.java:81)
      at hudson.maven.MavenModuleSetBuild$Builder.postExecute(MavenModuleSetBuild.java:772)
      at hudson.maven.MavenBuilder$Adapter.postExecute(MavenBuilder.java:300)
      at hudson.maven.agent.PluginManagerInterceptor$1MojoIntercepterImpl.callPost(PluginManagerInterceptor.java:170)
      at hudson.maven.agent.PluginManagerInterceptor.executeMojo(PluginManagerInterceptor.java:183)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.lifecycle.LifecycleExecutorInterceptor.execute(LifecycleExecutorInterceptor.java:65)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at hudson.maven.agent.Main.launch(Main.java:165)
      at hudson.maven.MavenBuilder.call(MavenBuilder.java:165)
      at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:694)
      at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:638)
      at hudson.remoting.UserRequest.perform(UserRequest.java:114)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:270)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.util.concurrent.ExecutionException: hudson.util.IOException2: Failed to extract /xdata/hudson/.hudson/jobs/Build_Foundation/workspace/target/site/*/
      at hudson.remoting.Channel$2.adapt(Channel.java:663)
      at hudson.remoting.Channel$2.adapt(Channel.java:658)
      at hudson.remoting.FutureAdapter.get(FutureAdapter.java:55)
      at hudson.FilePath.copyRecursiveTo(FilePath.java:1472)
      ... 35 more
      Caused by: hudson.util.IOException2: Failed to extract /xdata/hudson/.hudson/jobs/Build_Foundation/workspace/target/site/*/
      at hudson.FilePath.readFromTar(FilePath.java:1577)
      at hudson.FilePath.access$100(FilePath.java:159)
      at hudson.FilePath$32.invoke(FilePath.java:1463)
      at hudson.FilePath$32.invoke(FilePath.java:1460)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1899)
      ... 9 more
      Caused by: java.util.zip.ZipException: invalid block type
      at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:147)
      at java.util.zip.GZIPInputStream.read(GZIPInputStream.java:92)
      at org.apache.tools.tar.TarBuffer.readBlock(TarBuffer.java:257)
      at org.apache.tools.tar.TarBuffer.readRecord(TarBuffer.java:223)
      at hudson.org.apache.tools.tar.TarInputStream.read(TarInputStream.java:345)
      at java.io.FilterInputStream.read(FilterInputStream.java:90)
      at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1025)
      at org.apache.commons.io.IOUtils.copy(IOUtils.java:999)
      at hudson.util.IOUtils.copy(IOUtils.java:33)
      at hudson.FilePath.readFromTar(FilePath.java:1565)
      ... 13 more

        Attachments

          Issue Links

            Activity

            micha4311 micha4311 added a comment -

            here is another one: JENKINS-7922 (NegativeArraySizeException) which could be related

            chaoslayer CHaoSlayer added a comment -

            We have similar problems here too in various maven projects which seem to be some kind of race condition.

            Some days they run fine, some other day they fail, hammering our mailboxes.

            Can't you just put some system property into the maven archiver code that we can use to disable archiving?

            This would be a good idea in general, because (at least we) don't need archived artifacts/sites/... anywhere. They just fill up the disk.

            kohsuke Kohsuke Kawaguchi added a comment -

            I believe the root cause is JENKINS-7745.

            kohsuke Kohsuke Kawaguchi added a comment -

            I believe the root cause is JENKINS-7745.

            kohsuke Kohsuke Kawaguchi added a comment -

            Marking as a duplicate.


              People

              • Assignee:
                Unassigned
                Reporter:
                lynggaard lynggaard
              • Votes:
                7 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: