Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Environment:
      Fedora 10 x86_64 Master, Win7 32bit Slave
    • Similar Issues:

      Description

      We are running 1.380. I can watch a 300MB tarball get transferred to the Hudson master slowly over 30+ minutes. An scp between the same machines and same files/directories takes less than 3 minutes.

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            @tomfanning, @davidkarlsen2, @pancake: as http://jenkins-ci.org/changelog notes, these changes are in Jenkins 1.509. That will be the basis of the next LTS.

            emszpak Marcin Zajączkowski added a comment -

            I see no changes after upgrade to 1.515 (with slave upgraded to 2.23). 43MB WAR archives in 102 seconds vs. <2 seconds with SCP. No one confirmed on the mailing list that was able to get significant change after upgrade.

            jglick Jesse Glick added a comment -

            @emszpak: reclosing since the intended fixes were delivered. There may be other as-yet-undiagnosed problems slowing down your connection; someone would need to reproduce the issue, file separately (can use JIRA links), and analyze it.

            salsolatragus Sven Amann added a comment -

            Not sure about the connection, but same symptoms.

            sodul Stephane Odul added a comment -

            I can confirm the same issue. The files take 10s to publish to our maven repo at the end of the build but before that they take over 4m to publish back to the master. I initially blamed a slow VM as the existing master but after upgrading to fresh hardware today and switching from CentOS to Ubuntu 12.04 we are still getting the issue. We are running Jenkins 1.527 with Java 1.7.0_17 (not open jdk).


              People

              • Assignee:
                Unassigned
                Reporter:
                gtuhl gtuhl
              • Votes:
                40 Vote for this issue
                Watchers:
                46 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: