Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7816

Artifactory deploy plugin depends on Ivy, even if there are no Ivy builds configured (and the Ivy plugin is not installed)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: artifactory-plugin
    • Labels:
      None
    • Environment:
      Tomcat 6.0.29, Hudson 1.381, latest release of Artifactory plugin
    • Similar Issues:

      Description

      Hello,

      Our Tomcat log is polluted by all sorts of entries like these:
      Oct 17, 2010 2:12:01 PM hudson.ExtensionFinder$Sezpoz scout
      WARNING: Failed to scout org.jfrog.hudson.ivy.ArtifactoryIvyRunListener
      java.lang.NoClassDefFoundError: hudson/ivy/IvyModuleSetBuild
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Unknown Source)
      at hudson.ExtensionFinder$Sezpoz.scout(ExtensionFinder.java:188)
      at hudson.ExtensionList.scoutLoad(ExtensionList.java:245)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:212)
      at hudson.ExtensionList.iterator(ExtensionList.java:113)
      at hudson.Launcher.decorateFor(Launcher.java:569)
      at hudson.model.Slave.createLauncher(Slave.java:308)
      at hudson.model.AbstractBuild$AbstractRunner.createLauncher(AbstractBuild.java:443)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:401)
      at hudson.model.Run.run(Run.java:1280)
      at hudson.matrix.MatrixBuild.run(MatrixBuild.java:152)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:139)
      at hudson.model.OneOffExecutor.run(OneOffExecutor.java:61)
      Caused by: java.lang.ClassNotFoundException: hudson.ivy.IvyModuleSetBuild
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      ... 15 more

      despite the fact that we have no Ivy builds.

      See this issue for more details about it:
      http://issues.jenkins-ci.org/browse/JENKINS-7380

      It's not blocking anymore since Hudson does not crash, but we already have lots of info in the logs, we don't need any more unnecessary warnings.

      Thank you.

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : jfrog
          Path:
          trunk/hudson/plugins/artifactory/src/main/java/org/jfrog/hudson/ivy/ArtifactoryIvyRunListener.java
          http://jenkins-ci.org/commit/36020
          Log:
          JENKINS-7816 - Artifactory deploy plugin depends on Ivy, even if there are no Ivy builds configured (and the Ivy plugin is not installed) - check type of descriptor at runtime

          tomerc tomerc added a comment -

          This issue was re-opened at the following:

          http://issues.jfrog.org/jira/browse/HAP-94

          yossis yossis added a comment -

          Fixed in version 1.3.2


            People

            • Assignee:
              yossis yossis
              Reporter:
              ccaraivan Costin Caraivan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: