Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8001

ERROR: Publisher hudson.plugins.ircbot.IrcPublisher aborted due to exception

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: ircbot-plugin
    • Labels:
      None
    • Environment:
      Linux RHEL 5.5 x64 / jre 1.6_22
      Hudson ver: Hudson ver. 1.383 and Hudson ver. 1.382
    • Similar Issues:

      Description

      After a successfull maven2 build the following exception is coming up. The exception is reproducible in all maven build jobs. Theses errors occurred after upgrading to 1.383 . Did a downgrade to 1.38.2. But still the sames errors. Maybe it is just a coincidence.

      ERROR: Publisher hudson.plugins.ircbot.IrcPublisher aborted due to exception
      java.lang.NullPointerException
      at hudson.plugins.im.IMPublisher.notifyChats(IMPublisher.java:430)
      at hudson.plugins.im.IMPublisher.perform(IMPublisher.java:273)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:580)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:595)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
      at hudson.model.Run.run(Run.java:1304)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:293)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:139)
      FATAL: null
      java.lang.NullPointerException
      at java.lang.String.startsWith(String.java:1421)
      at java.lang.String.startsWith(String.java:1450)
      at hudson.maven.MavenModuleSetBuild$1.isDescendantOf(MavenModuleSetBuild.java:178)
      at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:147)
      at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:141)
      at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:51)
      at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:161)
      at hudson.model.AbstractBuild.hasParticipant(AbstractBuild.java:315)
      at hudson.model.AbstractProject.hasParticipant(AbstractProject.java:1255)
      at hudson.model.User.getProjects(User.java:381)
      at hudson.scm.SubversionMailAddressResolverImpl.findMailAddressFor(SubversionMailAddressResolverImpl.java:20)
      at hudson.tasks.MailAddressResolver.resolve(MailAddressResolver.java:97)
      at hudson.tasks.Mailer$UserProperty.getAddress(Mailer.java:496)
      at hudson.tasks.MailSender.buildCulpritList(MailSender.java:380)
      at hudson.tasks.MailSender.createEmptyMail(MailSender.java:345)
      at hudson.tasks.MailSender.createFailureMail(MailSender.java:219)
      at hudson.tasks.MailSender.getMail(MailSender.java:146)
      at hudson.tasks.MailSender.execute(MailSender.java:94)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.cleanUp(MavenModuleSetBuild.java:619)
      at hudson.model.Run.run(Run.java:1323)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:293)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:139)

      Any Idea ?

      Cheers

      Sisko

        Attachments

          Issue Links

            Activity

            kutzi kutzi added a comment -

            This is another duplicate of JENKINS-7684

            afoglia Anthony Foglia added a comment -

            Are you sure this is a duplicate of the Maven issue? I'm getting a similar NullPointerException, but we're a C++ and Python team, and don't use Maven at all. (We're using Hudson ver 1.384.)

            Here's the stack trace:
            ERROR: Publisher hudson.plugins.ircbot.IrcPublisher aborted due to exception
            java.lang.NullPointerException
            at hudson.plugins.im.IMPublisher.notifyChats(IMPublisher.java:430)
            at hudson.plugins.im.IMPublisher.perform(IMPublisher.java:273)
            at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
            at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
            at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:580)
            at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:558)
            at hudson.model.Build$RunnerImpl.post2(Build.java:157)
            at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
            at hudson.model.Run.run(Run.java:1348)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:139)
            Finished: FAILURE

            It looks like the fix for JENKINS-7684 should be in the next version. If so, and if it fixes the problem, I'll close the issue again.

            kmmoens kmmoens added a comment -

            We face the same issues since our latest upgrade of the plugin. We are not using Maven at all in our builds, we only use Ant.

            ERROR: Publisher hudson.plugins.ircbot.IrcPublisher aborted due to exception
            java.lang.NullPointerException
            at hudson.plugins.im.IMPublisher.notifyChats(IMPublisher.java:430)
            at hudson.plugins.im.IMPublisher.perform(IMPublisher.java:273)
            at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
            at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
            at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:580)
            at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:558)
            at hudson.model.Build$RunnerImpl.post2(Build.java:157)
            at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
            at hudson.model.Run.run(Run.java:1348)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:139)

            kutzi kutzi added a comment -

            Sorry, you're right. These are indeed 2 different issue.
            The 1st (java.lang.NullPointerException at java.lang.String.startsWith) is a duplicate of JENKINS-7684.
            But the other is a dup of JENKINS-8067

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kutzi
            Path:
            trunk/hudson/plugins/instant-messaging/src/main/java/hudson/plugins/im/IMPublisher.java
            trunk/hudson/plugins/ircbot/src/main/java/hudson/plugins/ircbot/IrcPublisher.java
            http://jenkins-ci.org/commit/36912
            Log:
            [FIXED JENKINS-8001] [FIXED JENKINS-8067] NPE in IrcPublisher because of incomplete deserialization of old instances

            kutzi kutzi added a comment -

            Fixed in IrcBot 2.8

            sisko255 sisko255 added a comment -

            Awesome ! I`ll test it later !


              People

              • Assignee:
                kutzi kutzi
                Reporter:
                sisko255 sisko255
              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: