Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8002

Split job build and job abort authorization

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      See http://hudson.361315.n4.nabble.com/Any-way-to-split-job-build-and-job-abort-authorization-tp3027097p3027097.html .

      I think it would be sane to allow for users to have authorization to start builds, but not to abort them. The authorization for both is currently lumped under Job/Build.

        Attachments

          Issue Links

            Activity

            oeuftete oeuftete created issue -
            danielbeck Daniel Beck added a comment -

            Resolving as duplicate of JENKINS-8002 as that one has more watchers.

            danielbeck Daniel Beck made changes -
            Field Original Value New Value
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            danielbeck Daniel Beck added a comment -

            Sorry, meant JENKINS-14713

            danielbeck Daniel Beck made changes -
            Link This issue duplicates JENKINS-14713 [ JENKINS-14713 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 138105 ] JNJira + In-Review [ 187848 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                oeuftete oeuftete
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: