Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8064

Perforce plugin incorrectly finds changes

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: perforce-plugin
    • Labels:
      None
    • Environment:
      Hudson 1.383
      Perforce plugin 1.1.11
      p4 Rev. P4/LINUX26X86/2009.1/205670 (2009/06/29)
    • Similar Issues:

      Description

      I have a project that hasn't changed (no checkins to Perforce), building on a slave (that hasn't changed either). Yet the P4 plugin thinks there are changes and kicks off a build several times a day.

      The polling log shows:

      Started on Nov 10, 2010 9:29:10 AM
      Looking for changes...
      Using node: builder-ubuntu-jaunty-32-nutmeg
      Using remote perforce client: hudson-unitpp-linux32--497286900
      [unitpp-Linux-32] $ /usr/local/bin/p4 workspace -o hudson-unitpp-linux32--497286900
      Changing P4 Client Root to: /home/boss/hudson/workspace/unitpp-Linux-32
      Changing P4 Client View from:

      Changing P4 Client View to:
      //depot/External/unit++/... //hudson-unitpp-linux32--497286900/...
      -//depot/External/unit++/Lib/... //hudson-unitpp-linux32--497286900/Lib/...
      -//depot/External/unit++/Include/... //hudson-unitpp-linux32--497286900/Include/...
      Done. Took 0.45 sec
      Changes found

        Attachments

          Issue Links

            Activity

            rpetti Rob Petti added a comment - - edited

            Do changes show up in the changelog of the resulting build?

            Also, does this happen every time the polling runs, or only intermittently? Hudson 1.378 introduced a major master-slave communication issue that is adversely affecting the perforce plugin. It has yet to be fixed, so you will experience problems if you are using the perforce plugin with slaves.

            ickersep ickersep added a comment -

            No, no changes show up anywhere.

            It happens intermittently. It might very well be that it is related to the master/slave communication issue. I think it started after I upgraded 1.377 to 1.383.

            I downgraded to 1.377 and will see if the problem still happens.

            Do you have a bug number for this master/slave communication bug?

            rpetti Rob Petti added a comment -

            JENKINS-7809 is the root cause, and JENKINS-7664 is another symptom.

            rpetti Rob Petti added a comment -

            We've got a work-around for JENKINS-7664, so this one should also be fixed in the next release.

            rpetti Rob Petti added a comment -

            Issue wasn't fully fixed.

            rbracewell rbracewell added a comment -

            I am seeing the same issues across our farm we have several hundred projects being triggered. As an example when I drill down into a build that is triggered it reports "No changes from last build." but also reports Started by an SCM change

            When I look at the polling history it reports:
            Polling Log
            View as plain text

            This page captures the polling log that triggered this build.

            Started on Nov 24, 2010 1:16:08 PM
            Looking for changes...
            Using node: node04
            Using remote perforce client: hudson_project1-178203
            [project1_pollscm] $ /local/mnt/workspace/perforce/bin/p4 workspace -o hudson_project1-178203
            Changing P4 Client Root to: /local/mnt/workspace/Hudson/workspace/project1_pollscm
            Changing P4 Client View from:

            Changing P4 Client View to:
            //components/project1/HEAD/... //hudson_project1-178203/...
            Done. Took 5.9 sec
            Changes found

            rpetti Rob Petti added a comment -

            Because of the random failures in the remoting api, the perforce plugin occasionally doesn't get anything back when it requests the current client from perforce. As a result, it thinks the client is new. Since a new client will almost always have new changes, the plugin launches a new build. I've changed the logic so it won't launch a new build automatically, but will proceed with the changelist number comparison as normal.

            rpetti Rob Petti added a comment -

            Fixed in 1.2.0.


              People

              • Assignee:
                rpetti Rob Petti
                Reporter:
                ickersep ickersep
              • Votes:
                4 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: