Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-815

Hg poll fails when there is no default branch

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I have created my own hg repository by converting it from svn one. It does not
      have the "default" branch and as a result the poll seems to fail:

      Started on Sep 14, 2007 12:06:51 PM
      [workspace] $ hg id default
      Failed to check the tip revision
      null
      hudson.AbortException
      at
      hudson.plugins.mercurial.MercurialSCM.getTipRevision(MercurialSCM.java:80)
      at
      hudson.plugins.mercurial.MercurialSCM.pollChanges(MercurialSCM.java:56)
      at
      hudson.model.AbstractProject.pollSCMChanges(AbstractProject.java:526)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:234)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:266)
      at
      java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      Done. Took 0 seconds
      No changes

      Moreover there seems to be on UI to configure the branch I want the hudson to
      use.

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Branch support and version detected implemented in 1.3. The release of this
          plugin is pending Hudson 1.139.

          kohsuke Kohsuke Kawaguchi added a comment -

          When "hg id" fails, the plugin now dumps the output from hg, instead of a
          pointless stack trace.

          jst jst added a comment -

          Upgrading to 0.9.4 helped. So the only two low priority issue remain - if
          there is old version of hg, either report an error or do not use the hg id
          default. Plus add some UI to specify the branch that hg should use.

          jst jst added a comment -

          Even if I create the default branch, I seem to be out of luck. Maybe the
          problem is old HG?

          hg --version
          Mercurial Distributed SCM (version 0.9.3)

          But if so, it would be nice to have better error notification than just the
          above attached exception.


            People

            • Assignee:
              Unassigned
              Reporter:
              jst jst
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: